Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't run the SlickEdit installation on my Ubuntu machine. Following the vendor's instructions:

Run the installation at the prompt:

$ ./vsinst

Here are the details:

$ ll
-rwxr-xr-x  1 user user    645648 Aug 12 21:46 vsinst*

system

$ uname -a:

Linux xxx-linux-svn 3.8.0-35-generic #50~precise1-Ubuntu SMP 
Wed Dec 4 17:28:45 UTC 2013 i686 i686 i386 GNU/Linux

Details:

$ file vsinst
vsinst: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), 
dynamically linked (uses shared libs), for GNU/Linux 2.4.0, not stripped

$ ldd vsinst
not a dynamic executable

So, it's neither architectural incompatibility problem, nor permissions.

Tried 32-bit libs with:  
sudo apt-get install i386 && sudo ./vsinst

In vain, same result: ./vsinst: cannot execute binary file

Sorry and thanks for everyone!
The problem is in the 64-bit package offered by SE downloads page. Their 32-bit package works just fine.

share|improve this question
1  
And why can you not install it? Seems installed to me... or can you not execute it? Please elaborate by editing your question :) And do not be too sure about it not being architecture: what does ldd vsinst show? –  Rinzwind Jan 13 at 10:17
    
How did you install this program? What steps did you follow? –  Alvar Jan 13 at 10:30

2 Answers 2

Open the terminal, change directory using the command cd to the directory where the vsinst file is located, and run:

sudo ./vsinst  

If you are installing the 32-bit version of SlickEdit in a 64-bit operating system, run this command instead:

sudo apt-get install ia32-libs && sudo ./vsinst
share|improve this answer

Does installing ia32-libs help?

sudo apt-get install ia32-libs

Source:

Ubuntu x64 unable to install SlickEdit v13

Pertinent quotes:

It sounds like your Ubuntu 8.04 x64 install does not have the required 32 bit libraries to run the SlickEdit installer, because SlickEdit is a 32 bit app.

If you download the support packages for 32bit apps you should be able to get SlickEdit installed and running.

and

I installed the package ia32-libs to get SlickEdit 12 to run.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.