Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this array of approx 6TB (ext4) and i am getting a disk space error. I only have a total of 800GB to copy to the shares I have created.

I am using robocopy to copy this data from a windows domain server, the error message is similar for each of the files.

New File 107464 DSC00095.JPG 2014/01/14 09:52:22 ERROR 112 (0x00000070) Creating Destination Directory

 \\server-storage1\data-archive\2003\030907\08 Photos\ There is not
 enough space on the disk.

Any ideas what the problem is, where have I gone wrong?

 /dev/md0:
      Version : 1.2
      Creation Time : Fri Jan 10 16:47:14 2014
      Raid Level : raid5
      Array Size : 5860267648 (5588.79 GiB 6000.91 GB)   
      Used Dev Size : 2930133824 (2794.39 GiB 3000.46 GB)    
      Raid Devices : 3   Total
      Devices : 3
      Persistence : Superblock is persistent

      Update Time : Mon Jan 13 17:03:14 2014
      State : clean  Active Devices : 3 Working Devices : 3  Failed Devices : 0   Spare Devices : 0

          Layout : left-symmetric
      Chunk Size : 64K

            Name : server-bne-storage1:0
            UUID : 5474ef82:8beeded5:c2aaae98:d968bc74
          Events : 90767

     Number   Major   Minor   RaidDevice State
        0       8       17        0      active sync   /dev/sdb1
        1       8       33        1      active sync   /dev/sdc1
        3       8       49        2      active sync   /dev/sdd1

there is still 5.2tb available reported by df -h

/dev/md0    5.5T   58M  5.2T   1% /srv/samba/storage1

edit:

I have also mounted a cifs share and copy the files to the array as root and all worked ok until I got the following error msg. df still reports 5.2tb free.

1994/940396/396W-J05.DWG 695457 100% 2.71MB/s 0:00:00 (xfer#899, to-check=1011/2060) 1994/940396/396W-P01.DWG 32768 1% 104.23kB/s 0:00:23 rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32) rsync: write failed on "/srv/samba/data-archive/1994/940396/396W-P01.DWG": No space left on device (28) rsync: connection unexpectedly closed (17154 bytes received so far) [sender] rsync error: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9]

share|improve this question
    
Can you be more specific about the exact error message and the operation you tried which caused the error? –  kdmurray Jan 13 at 7:46
    
Additional information added. Error message & df disk stats –  user1542648 Jan 13 at 23:58
    
What about df -i? –  psusi Jan 14 at 4:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.