Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I dd'ed my 64gb flashdrive last week, and did not realise that the iso was corrupted until the dd was done.

The drive is no longer detected when plugging it and plugging it out. I tried it on a windows machine also, but obviously that computer couldn't handle it neither and said that the drivers for the usb stick didn't work.

So here i am, with a broken USB stick and can't even format it since linux doesn't give it a label. I do not care about the data on the drive, just want to fix it.

Does anyone have any ideas what i could do?

this is what dmesg returns when plugging in the USB-drive:

[989699.588042] usb 2-2: new high-speed USB device number 4 using ehci_hcd
[989699.722098] scsi7 : usb-storage 2-2:1.0
[989721.936053] usb 2-2: reset high-speed USB device number 4 using ehci_hcd
[989732.180053] usb 2-2: reset high-speed USB device number 4 using ehci_hcd
[989748.424054] usb 2-2: reset high-speed USB device number 4 using ehci_hcd
[989748.672037] usb 2-2: reset high-speed USB device number 4 using ehci_hcd
[989758.916054] usb 2-2: reset high-speed USB device number 4 using ehci_hcd
[989759.049323] scsi 7:0:0:0: Device offlined - not ready after error recovery
share|improve this question
add comment

2 Answers 2

sorry if this does not help, but did you try booting the pc with the stick plugged in to see if it recognizes it? i guess so the bios can see it.

i found this thread working on something similar.

i did a dd for an iso, now my stick will not automount. i thought i bricked it, but left it in the slot and noticed it was blinking when i rebooted the machine. at that time i ran dd again to undo the original hybrid config "that distro!!" needed. once i had a single partition again, i formatted it and then i could write to it. but it was still not automounting.

so now, i can only access it, if i boot with it in the usb slot and if i remove it during a session, lsblk no longer sees it, but lsusb does, as well as a syslog that has led me nowhere.

output of syslog

usb 1-2: can't set config #1, error -110
mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-2"   
mtp-probe: bus: 1, device: 4 was not an MTP device

it i have to reboot the pc to get hold of it again. i've redone dd, tried testdisk, gparted (made new partition table) and did a 'clean all' in windows disk part. it will even boot the pc with systemrescue, but it will not automount.

share|improve this answer
    
Thank you! This is exactly the case. You are right, it is detected in lsusb and in bios. I havn't rebooted my machine in multiple weeks, will do that when i can. I also get the same error message: mtp-probe: bus: 2, device: 5 was not an MTP device –  Johan Bjäreholt Jan 17 at 15:38
add comment

Did try Gparted? It will let you put a new partition table on it, then create a new one, then apply operations.

share|improve this answer
    
Like i said, the kernel isn't even giving it a label so gparted doesn't even show the device. –  Johan Bjäreholt Jan 13 at 10:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.