Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I have trouble in my ubuntu 11.04 LTS, This is what I got.

samuel@samuel:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  aisleriot alsa-utils appmenu-gtk apport apport-gtk apt apt-transport-https apt-utils aptdaemon apturl
  apturl-common aspell at-spi bamfdaemon banshee banshee-extension-soundmenu baobab base-files bash bind9-host
  binutils bluez bluez-alsa bluez-cups bluez-gstreamer bogofilter-bdb brasero brasero-cdrkit brasero-common brltty
  brltty-x11 bsdmainutils ca-certificates checkbox checkbox-gtk compiz compiz-core compiz-gnome compiz-plugins
  compiz-plugins-main compizconfig-backend-gconf computer-janitor computer-janitor-gtk console-setup consolekit
  coreutils cpp cpp-4.5 cups cups-bsd cups-client cups-driver-gutenprint dbus-x11 debianutils dnsmasq-base dnsutils
  doc-base empathy empathy-common eog espeak espeak-data evince evince-common evolution evolution-common
  evolution-data-server evolution-data-server-common evolution-exchange evolution-indicator evolution-plugins
  evolution-webcal exiv2 file-roller firefox foo2zjs foomatic-db-compressed-ppds foomatic-db-engine
  friendly-recovery fuse-utils g++ g++-4.5 gamin gbrainy gcalctool gcc gcc-4.5 gcc-4.5-base gconf-defaults-service
  gconf-editor gconf2 gconf2-common gdb gdm gedit gedit-common geoclue geoclue-ubuntu-geoip gettext ghostscript
  ghostscript-x ginn gir1.2-appindicator-0.1 gir1.2-freedesktop gir1.2-gconf-2.0 gir1.2-gdkpixbuf-2.0
  gir1.2-glib-2.0 gir1.2-pango-1.0 gir1.2-soup-2.4 glib-networking gnome-applets gnome-applets-data gnome-bluetooth
  gnome-control-center gnome-desktop-data gnome-disk-utility gnome-icon-theme gnome-keyring gnome-media
  gnome-nettool gnome-orca gnome-panel gnome-panel-data gnome-power-manager gnome-screensaver gnome-screenshot
  gnome-search-tool gnome-session gnome-session-bin gnome-session-canberra gnome-session-common
  gnome-settings-daemon gnome-sudoku gnome-system-log gnome-system-monitor gnome-system-tools gnome-terminal
  gnome-terminal-data gnome-user-share gnomine gnupg grub-common grub-pc gsettings-desktop-schemas
  gstreamer0.10-alsa gstreamer0.10-nice gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps
  gstreamer0.10-plugins-good gstreamer0.10-pulseaudio gstreamer0.10-tools gstreamer0.10-x gtk2-engines-murrine
  gtk2-engines-pixbuf gucharmap guile-1.8-libs gvfs gvfs-backends gvfs-fuse gwibber gwibber-service hpijs hplip
  hplip-cups hplip-data ibus ibus-gtk ibus-pinyin ibus-pinyin-db-android ibus-table ifupdown indicator-applet
  indicator-applet-appmenu indicator-applet-complete indicator-applet-session indicator-application
  indicator-appmenu indicator-datetime indicator-messages indicator-session indicator-sound info initscripts iproute
  iptables iputils-ping isc-dhcp-client isc-dhcp-common jockey-common jockey-gtk language-selector-common
  language-selector-gnome lftp libaa1 libalgorithm-diff-xs-perl libapparmor-perl libappindicator0.1-cil
  libappindicator1 libapt-pkg-perl libart2.0-cil libasound2 libasound2-plugins libaspell15 libatkmm-1.6-1
  libavahi-core7 libbamf0 libbluetooth3 libbonobo2-0 libbonobo2-common libbonoboui2-0 libc-bin libc-dev-bin libc6
  libc6-dev libcaca0 libcairo-perl libcanberra-gtk-module libcanberra-pulse libcanberra0 libcloog-ppl0
  libcompizconfig0 libcups2 libcupsimage2 libcupsmime1 libcurl3-gnutls libdb4.8 libdbus-glib-1-2 libdconf0
  libdecoration0 libdevmapper-event1.02.1 libdjvulibre21 libedit2 libenchant1c2a libespeak1 libevolution libexempi3
  libfs6 libfuse2 libgadu3 libgail-common libgail18 libgamin0 libgcc1 libgconf2-4 libgconf2.0-cil libgcrypt11
  libgd2-xpm libgdk-pixbuf2.0-0 libgdu-gtk0 libgirepository-1.0-1 libgkeyfile1.0-cil libgl1-mesa-dri libgl1-mesa-glx
  libglade2.0-cil libglib-perl libglib2.0-0 libglib2.0-bin libglib2.0-cil libglibmm-2.4-1c2a libgmpxx4ldbl
  libgnome-bluetooth8 libgnome-desktop-2-17 libgnome-keyring0 libgnome-vfs2.0-cil libgnome2-0 libgnome2.24-cil
  libgnomeui-0 libgnomevfs2-0 libgnutls26 libgomp1 libgpgme11 libgphoto2-2 libgphoto2-port0 libgs9 libgssapi-krb5-2
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk-sharp-beans-cil libgtk-vnc-1.0-0 libgtk2-perl
  libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtk2.0-common libgtkhtml3.14-19 libgtkmm-2.4-1c2a libgudev1.0-cil
  libhpmud0 libhtml-parser-perl libidl0 libimobiledevice2 libindicate5 libio-pty-perl libisofs6 libjack-jackd2-0
  libjasper1 libk5crypto3 libkrb5-3 libkrb5support0 liblaunchpad-integration1.0-cil libldap-2.4-2
  liblocale-gettext-perl liblockfile1 libmetacity-private0 libmission-control-plugins0 libmono-addins-gui0.2-cil
  libmono-addins0.2-cil libmono-corlib2.0-cil libmono-management2.0-cil libmono-posix2.0-cil libmono-security2.0-cil
  libmono-sharpzip2.84-cil libmono-system2.0-cil libmono-zeroconf1.0-cil libmpc2 libmpfr4 libncurses5 libncursesw5
  libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libneon27-gnutls libnet-dbus-perl libnet-dns-perl libnewt0.52
  libnice10 libnih-dbus1 libnih1 libnm-glib-vpn1 libnotify0.4-cil libnspr4 liborbit2 libpam-modules
  libpam-modules-bin libpango-perl libpango1.0-0 libpangomm-1.4-1 libpcsclite1 libpipeline1 libplymouth2
  libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpulse-mainloop-glib0 libpulse0 libpurple0
  libpython2.7 librdf0 libreadline6 libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-writer
  librpc-xml-perl librsvg2-2 librsvg2-common libsane libsane-hpaio libsasl2-2 libsasl2-modules libsdl1.2debian
  libsigc++-2.0-0c2a libsmbclient libsnmp15 libsoup-gnome2.4-1 libsoup2.4-1 libstartup-notification0 libstdc++6
  libstdc++6-4.5-dev libsub-name-perl libsyncdaemon-1.0-1 libtag1-vanilla libtag1c2a libtaglib2.0-cil
  libtelepathy-glib0 libtelepathy-logger2 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtiff4
  libtotem-plparser17 libusbmuxd1 libutouch-frame1 libutouch-geis1 libutouch-grail1 libuuid-perl libv4l-0
  libvorbis0a libvorbisenc2 libvorbisfile3 libvte-common libvte9 libwebkitgtk-1.0-0 libwmf0.2-7 libwmf0.2-7-gtk
  libwpd-0.9-9 libwps-0.2-2 libwww-perl libx11-6 libxapian22 libxaw7 libxcomposite1 libxcursor1 libxdamage1 libxext6
  libxfixes3 libxfont1 libxi6 libxinerama1 libxml-parser-perl libxml2 libxp6 libxrandr2 libxrender1 libxres1
  libxtst6 libxxf86dga1 libxxf86vm1 libzeitgeist-1.0-1 light-themes lintian linux-generic linux-headers-generic
  linux-image-generic metacity metacity-common min12xxw modemmanager mono-2.0-gac mono-csharp-shell mono-gac
  mono-gmcs mono-runtime mount mountall mousetweaks nautilus nautilus-data nautilus-sendto nautilus-sendto-empathy
  nautilus-share ncurses-bin network-manager network-manager-gnome network-manager-pptp network-manager-pptp-gnome
  notify-osd ntfs-3g ntpdate onboard openprinting-ppds openssh-client openssl overlay-scrollbar parted passwd perl
  perl-base perl-modules plymouth plymouth-label pnm2ppa policykit-1-gnome poppler-utils procps protobuf-compiler
  psmisc pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf
  pulseaudio-module-x11 pulseaudio-utils pxljr python python-appindicator python-apt python-aptdaemon
  python-aptdaemon-gtk python-aptdaemon.gtk3widgets python-aptdaemon.gtkwidgets python-cairo python-crypto
  python-dbus python-gconf python-glade2 python-gnome2 python-gnomekeyring python-gobject python-gst0.10 python-gtk2
  python-ibus python-imaging python-indicate python-libproxy python-minimal python-openssl python-protobuf
  python-pyatspi python-pycurl python-pyorbit python-ubuntuone-client python-ubuntuone-control-panel python-uno
  python-vte python-xapian python2.7 python2.7-minimal rdesktop rsyslog samba-common samba-common-bin seahorse
  sessioninstaller shotwell simple-scan smbclient software-center software-properties-gtk speech-dispatcher splix
  sudo synaptic sysvinit-utils tcl tcpdump telepathy-gabble telepathy-haze telepathy-idle telepathy-logger
  telepathy-mission-control-5 telepathy-salut tomboy totem totem-common totem-mozilla totem-plugins
  transmission-common transmission-gtk ttf-kacst-one ttf-khmeros-core ttf-lao ttf-liberation ttf-opensymbol
  ttf-takao-pgothic ttf-thai-tlwg ttf-unfonts-core ubuntu-desktop ubuntu-minimal ubuntu-sso-client ubuntu-wallpapers
  ubuntuone-client ubuntuone-client-gnome ubuntuone-control-panel ubuntuone-control-panel-gtk udev unity
  unity-common unity-place-applications unity-place-files uno-libs3 update-manager update-manager-core
  update-notifier update-notifier-common upower upstart ure usb-creator-common usb-creator-gtk util-linux vim-common
  vim-tiny vinagre vino wget whois wireless-crda wireless-tools wpasupplicant x11-utils xdg-user-dirs-gtk xkb-data
  xorg xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics
  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-apm xserver-xorg-video-ark
  xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-cirrus xserver-xorg-video-fbdev
  xserver-xorg-video-geode xserver-xorg-video-i128 xserver-xorg-video-i740 xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-mga xserver-xorg-video-neomagic xserver-xorg-video-nouveau
  xserver-xorg-video-openchrome xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx
  xserver-xorg-video-trident xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware
  xserver-xorg-video-voodoo xterm xz-utils yelp zeitgeist zeitgeist-core zenity
The following packages will be upgraded:
  nux-tools
1 upgraded, 0 newly installed, 0 to remove and 633 not upgraded.
Need to get 0 B/11.2 kB of archives.
After this operation, 23.6 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 144563 files and directories currently installed.)
Preparing to replace nux-tools 0.9.46-0ubuntu4 (using .../nux-tools_2.14.1-0ubuntu1_i386.deb) ...
Unpacking replacement nux-tools ...
dpkg: error processing /var/cache/apt/archives/nux-tools_2.14.1-0ubuntu1_i386.deb (--unpack):
 trying to overwrite '/usr/share/apport/package-hooks/source_nux.py', which is also in package libnux-0.9-common 0.9.46-0ubuntu4
Errors were encountered while processing:
 /var/cache/apt/archives/nux-tools_2.14.1-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried this one but it always the same error I got :

sudo dpkg -r libjack-jackd2-0
sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

Please Help ...

share|improve this question
2  
11.04 is not an LTS release, and has reached its end of life and is no longer supported (and off-topic here). –  amc Jan 13 at 4:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.