Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have new Lenovo laptop with pre-installed Windows 8. I was facing issues installing Ubuntu l2.04 LTS, so following a thread I made some changes, created some ext4, swap, bootloader partitions and then ubuntu installation worked miraculously . Also, what I did was converted my system to boot from Legacy instead of UEFI (secure boot).

Now, my system is not able to boot into Windows and it boots to Ubuntu directly and when I am trying to convert my Ubuntu to boot from EFI using Boot Repair, it tells me that my system is configured to boot from Legacy.

How do I get my system to show me prompt for me to select Windows or Ubuntu at bootup ?

NOTE: My Windows is not deleted, it exists, all its file exits, which I can access from Ubunt.

Thanks so much for all the help.

share|improve this question
3  
Might I suggest "Boot-Repair"? help.ubuntu.com/community/Boot-Repair –  vivid_vibe Jan 13 at 2:41

3 Answers 3

It seems your grub menu or bootloader. First boot into Ubuntu OS and then open terminal by pressing Ctrl+Alt+T. Then run sudo update-grub command in terminal. If it doesn't work type sudo nautilus in the terminal and press Enter. From the window that opens, go to /etc/default/grub and change GRUB_HIDDEN_TIMEOUT=0 TO GRUB_HIDDEN_TIMEOUT=10 and GRUB_HIDDEN_TIMEOUT_QUIET=true to GRUB_HIDDEN_TIMEOUT_QUIET=false. Save it. Then run sudo update-grub. On restart you can make the boot menu appear by holding Shift.

share|improve this answer
2  
+1 for sudo update-grub.Edit your answer as "boot into ubuntu os then open up the terminal" like that. –  Avinash Raj Jan 13 at 2:38
    
This problem cannot be solved by GRUB fiddling alone; the problem is that Windows is booting in EFI mode and Linux is booting in BIOS/CSM/legacy mode (via GRUB). GRUB can't switch boot modes. Instead, either Windows must be converted to boot in BIOS mode (which is hard) or Linux must be converted to boot in EFI mode (which is easier; see LovinBuntu's response). A third option is to use rEFInd to switch boot modes dynamically, but using EFI mode alone is likely to be easier. (You can use rEFInd for an EFI-only boot, too.) –  Rod Smith Jan 16 at 13:25

Windows is installed in UEFI mode, but Ubuntu is currently installed in Legacy mode.

You must convert Ubuntu into UEFI mode in order to be able to boot both systems from the GRUB menu.

share|improve this answer
    
correct, but when doing so,m it gives me a warning message saying your bios is set to legacy and if I do convert this, I might not be able to boot into anything. Also, when I still continue, it says I have to delete the grub 2 or files from grub 2, which basically scared me off. –  Kapil Chokhawala Jan 14 at 22:09
    
to convert Ubuntu in UEFI mode, you need first to set up your BIOS in UEFI mode, then use Boot-Repair. Don't use B-R if it says your BIOS is in Legacy mode. –  LovinBuntu Jan 16 at 0:59
    
LovinBuntu is absolutely correct. The oft-repeated advice to switch to BIOS/CSM/legacy mode for a dual-boot with a pre-installed Windows 8 is BAD ADVICE! Although it sometimes works around some initial difficulties, it usually leads to problems like yours, which can be harder to solve. –  Rod Smith Jan 16 at 13:21

Thanks, for the answer. I did you have said, but I could still not boot into windows. So, after future accessment, I found that when I change the Boot to UEFI, I do get the option to chose Windows and Ubuntu. But when I select Ubuntu, it shows me an error . But it does let me login to Windows successfully. All my documents and settings are as it is, nothing is lost.

Now when I change the bios boot to Legacy, I again get the option to select but when I select Windows 8, it gives me an error saying "file not found", but I can login to Ubuntu in this case.

Using Boot-Repair, when trying to change the Ubuntu to UEFI under Locations, it gives me an error saying your system is set to boot from Legacy, change that first or else you might not be able to boot into anything.

Thanks for your help in advance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.