Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can install Ubuntu 13.10 in parallels ok and then log in. Problem is Ubuntu does an update and I get black screen / desktop such that I can't see any app windows that I open. I've tried a few of the other suggestions and they don't work for me.

share|improve this question
    
What other suggestions? Please include what you have already tried and links to any sites you have got solutions from. That will help us a lot. Thanks! –  RPi Awesomeness Jan 13 at 3:39
    
I tried the solutions offered in this post: askubuntu.com/questions/360732/… –  Whitty Jan 14 at 1:27
    
RPi Awesomeness - just wondering if you had a chance to consider what might be the way to resolve the issue? I could wait for another release? –  Whitty Jan 21 at 21:35
    
I haven't looked into it very much, seeing as I don't use Macs. I can pop your question into chat if you want. –  RPi Awesomeness Jan 21 at 21:48

5 Answers 5

Same problem here with a MacBook Pro. Here's what worked for me after I updated 13.10 and received a black screen, although the toolbar on the left was showing. It was simple, but I don't know why it worked.

  1. Shut down the Ubuntu VM (13.10)
  2. In Parallels 9 config for the VM, go to Hardware > Video, and disable 3D acceleration.
  3. Restart Ubuntu 13.10. You will now get a completely black screen.
  4. Shut down the Ubuntu VM once more.
  5. Again, in Parallels config for the VM, go to Hardware > Video and reenable 3D acceleration.
  6. Restart, and you're back in business (No black screen and everything properly updated).
share|improve this answer
    
I only wish you had posted this 3 days earlier, when I was last looking at this question and despairing. =) –  Michael Mar 12 at 16:11
    
You are a genious. –  Ali Apr 25 at 18:19
1  
The same fix worked for me with Ubuntu 14.04 in Parallels 10. Thanks! –  hatch Sep 5 at 14:10
    
Parallels 9 updated itself and the same problem returned (Ubuntu 14.01). This set of steps worked to fix it again. –  Michael Sep 9 at 21:28
    
great, thanks! (I needed to find the shut down option on the icon in the taskbar of my iMac by right clicking the icon and navigating to the actions menu. took me ages to find it! –  CommentLuv Nov 10 at 18:09

[I just realized the post above me has a MUCH simpler solution, by rechecking the video acceleration in the VM settings. Doh!]

I have a solution. Reinstalling Parallels Tools blindly does the trick.

This just happened to me, with Mavericks, Parallels 9.0.24172, Ubuntu 13.10 and updates installed on 1 Mar 2014. On reboot, I could see the login screen, then after logging in, I could see the Unity "Launcher" or whatever the call the row of icons on the left, but the rest of the screen was black. If I click to start any apps, like Firefox, the icon in the bottom of the Parallels screen indicate that the re is disk activity as the app starts, but the screen remains black.

To fix:

  • From the Parallels Desktop "Virtual Machine" menu, choose "Reinstall Parallels Tools..."
  • You will see the CD-Rom and Hard Disk icons in the bottom of the Parallels window blink green
  • Wait about 10 seconds until the Hard Disk icon settles down
  • Blindly type your password (make sure Parallels has focus in Mavericks)
  • You'll see the Hard Disk icon blinking green some more.
  • After a few minutes (I waited 5, just to be safe), make sure Parallels still has focus, and hit the Return key. Parallels will reboot.
  • Voilá! On reboot and re-login, the desktop is visible

Just before I installed the Ubuntu updates, Parallels Tools had reinstalled itself, due to a new version of the Tools since I last used the VM, but it seems that certain kinds of Linux updates break the video driver. As stated above, always make a Parallels snapshot before running Ubuntu update, just to be safe.

share|improve this answer

Same problem here with a MacBook Pro. Here's what worked for me after I updated 13.10 and received a black screen, although the toolbar on the left was showing. It was simple, but I don't know why it worked.

Shut down the Ubuntu VM (13.10) In Parallels 9 config for the VM, go to Hardware > Video, and disable 3D acceleration. Restart Ubuntu 13.10. You will now get a completely black screen. Shut down the Ubuntu VM once more. Again, in Parallels config for the VM, go to Hardware > Video and reenable 3D acceleration. Restart, and you're back in business (No black screen and everything properly updated).


Using Parallels Desktop 10 and installed Ubuntu 14.04.1

The solution:

  1. Do a fresh install of Ubuntu 14.04.1 via it's ISO image with Parallels Desktop 10.

  2. Once you are logged into Ubuntu do a manual install of Parallel Tools, reboot.

  3. Login and run in a terminal;

    sudo apt-get update
    sudo apt-get upgrade
    sudo reboot
    
  4. Log in and you should see your black screen!

  5. Using Parallels Desktop's menu do a Shutdown.

  6. In Parallels Desktop Control Center do a Configure ...

  7. Under Hardware -> Video disable 3D Acceleration.

  8. Restart Ubuntu.

  9. Login to Ubuntu and run the Software Updater.

  10. Wait for it to do its thing and shutdown.

  11. Go back into Parallels Desktop Control Center and reenable 3D Acceleration

  12. Restart Ubuntu and login.

share|improve this answer

I experienced the blank screen issue with Parallels 9.0, Ubuntu 13.04, Mavricks on a macbook air. This worked for me

  1. Shutdown
  2. In Parallels 9 config for the VM, go to Hardware > Video, and disable 3D acceleration.
  3. Restart and update Parallels tools
  4. Enable 3D acceleration
share|improve this answer

What worked for me was this:

  • Switch to console (focus on black screen and press Fn+Ctrl+Alt and whilst holding that press F1)
  • Log in with user parallels (or what ever user your using)
  • Follow this article on installing the tools from command prompt - http://kb.parallels.com/en/113394

Basically, once I found the image and placed it on the CDROM drive I mounted within the os:

sudo mount /dev/cdrom /media/<username>/CDROM

Then executed the install program and updated the tool!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.