Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With the following commands

wget ftp://ftp.gnu.org/gnu/octave/octave-3.8.0.tar.bz2
tar -xvf octave-3.8.0.tar.bz2
cd octave-3.8.0
sudo apt-get build-dep octave
./configure
make
sudo make install

I have errors in the make and make install phases and octave does not install. Do you have any suggestion? Thanks for any help

Here are the error messages at the end of the make and make install commands:

/usr/local/include/llvm/PassManager.h:34:15: error: 'PassManager' is already declared in this scope
/usr/local/include/llvm/PassManager.h:35:15: error: 'FunctionPassManager' is already declared in this scope
corefcn/pt-jit.cc: In member function 'bool tree_jit::initialize()':
corefcn/pt-jit.cc:1891:48: error: cannot convert 'llvm::legacy::PassManager*' to 'llvm::PassManager*' in assignment
corefcn/pt-jit.cc:1892:22: error: invalid use of incomplete type 'struct llvm::PassManager'
corefcn/jit-util.h:46:9: error: forward declaration of 'struct llvm::PassManager'
corefcn/pt-jit.cc:1894:55: error: cannot convert 'llvm::legacy::FunctionPassManager*' to 'llvm::FunctionPassManager*' in assignment
corefcn/pt-jit.cc:1896:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1900:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1901:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1902:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1903:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1904:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1905:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1906:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:1907:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc: In member function 'void tree_jit::optimize(llvm::Function*)':
corefcn/pt-jit.cc:2003:22: error: invalid use of incomplete type 'struct llvm::PassManager'
corefcn/jit-util.h:46:9: error: forward declaration of 'struct llvm::PassManager'
corefcn/pt-jit.cc:2004:15: error: invalid use of incomplete type 'struct llvm::FunctionPassManager'
corefcn/jit-util.h:45:9: error: forward declaration of 'struct llvm::FunctionPassManager'
corefcn/pt-jit.cc:2010:34: error: 'F_Binary' is not a member of 'llvm::raw_fd_ostream'
make[3]: *** [corefcn/corefcn_libcorefcn_la-pt-jit.lo] Error 1
make[2]: *** [install] Error 2
make[1]: *** [install-recursive] Error 1
make: *** [install] Error 2
share|improve this question
add comment

4 Answers 4

This is an issue with building octave 3.8.0 against LLVM >= 3.4. There is updated information in this bug report: https://savannah.gnu.org/bugs/?41061

share|improve this answer
add comment

i installed the 3.8 octave version following this instruction - works great. there is a quite long list of dependencies packages which is also instilled if you follow the instructions.

http://blogs.bu.edu/mhirsch/2013/12/compiling-octave-3-8/

cheers seeb

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  MadMike Feb 2 at 0:05
add comment


Apparently, you didn't install important libraries along with Octave as I glanced the error message. My suggestion goes with Installing Octave properly from ubuntu software center, then it will automatically detect which library is missing from your system, thus adding it and installing it along with Octave. If you don't know how to install from ubuntu software center just tell me , I can instruct you step by step.

Thank you

share|improve this answer
    
Thank you for your suggestion. Unfortunately Ubuntu software center installs octave version 3.2.4 while I would install the last version: octave version 3.8.0. I see that the problem should be LLVM libray (which I installed) but I don't know how to proceed. Thank you again for any suggestion –  user235019 Jan 14 at 11:13
add comment

llvm is used by the optional jit. The jit makes octave perform better but it is not strictly necessary. To prevent the octave build from looking for llvm, use the --disable-jit flag like so:

./configure --disable-jit
make
sudo make install
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.