Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

IMPORTANT: Ubuntu Classic (without effects) works. I am trying to get unity to work.

Have the following problem with Ubuntu 11.04 (had it with 10.10 too, but disabling KMS or using the fglrx driver fixed it - cant remember exactly which). But now since the radeon driver is better than it used to i want to use it + fglrx performance kinda sucks.

So, ubuntu boots normaly until the login screen. After login it shows the background, the mouse is shown and it just remains there, it does not load the anything else. It does not freeze. I can move the mouse and can go into text console(ctrl+alt+f1).

It does not work on Ubuntu profile (Unity) or on the Ubuntu Classic (gnome + effects) profile. I even tried installing Gnome3 from their ppa, but it does not finish loading either (just like the other two).

Now my hardware : notebook Toshiba Satellite M40, Ati Radeon x600 (128mb) video card.

I haven't been able to find any errors in dmesg or other logs.

Update1:

Alt+F2 does not work. Nothing pops up. There is a gnome panel loaded (I see the process in the text console) when trying Ubuntu classic (with effects). Even the unity panel service loads when I use the Ubuntu profile. I get the impression that something doesn't finish loading (in both Ubuntu and classic with effects) because if I move the mouse over to where the toolbar would be I get the working mouse.

The thing is with fglrx I get an error when trying to load unity, saying to use classic because of lack of hardware. But with the radeon driver I don't get that error, they seem to start loading but never end. They just hang.

It would be nice if radeon driver would allow me to use effects/unity/gnome3 since unity seems to run ok on an intel 945m Express integrated video card notebook. Hope updates to the driver/unity will fix my problem.

$ /usr/lib/nux/unity_support_test -p

OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV380
OpenGL version string: 2.1 Mesa 7.10.2
Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes
Unity supported: yes

Since the unity script says that I should be running unity I am leaving this question open.

Found lots of bugs related to this (i think) like ubuntu bug 777341 and ubuntu bug 758482 and lots of questions relating to it on this very site / other sites. So I will assume that this is a problem that will be resolved in ulterior Ubuntu updates.

Update 2 :

Fiddling with compiz plugins (Gnome Plugin or Unity Plugin) in CCSM does not do the trick either.

The same goes for unistalling compiz/unity and reinstalling it.

Am starting to get the feeling that this is not a thing easy to fix, and only a driver (radeon/r300g/Gallium) / compiz / unity Ubuntu update will fix this. Will probably close question soon .

Feel free to leave your opionions / fixes here and i will try them and answer.

Any ideeas? I am willing to try everything to get it to work.

share|improve this question
add comment

4 Answers

Second Attempt
Go to a command line Ctrl + Alt + F1.
Create this folder:

mkdir  ~/.config/autostart

Create this file:

nano ~/.config/autostart/gnome.desktop  

Paste this into it:

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon[en_US]=gnome-panel
Name[en_US]=Gnome
Exec=gnome-panel
Name=Gnome
Icon=gnome-panel

Then

sudo reboot now

First Attempt
I needed to put gnome-panel as a command at Startup Applications (Alt + F2 and pastegnome-session-properties) to fix something like this. Can you test it?

share|improve this answer
    
Alt+F2 does not work. Nothing pops up. –  Octav S May 5 '11 at 17:45
    
I've edited the answer. Hope this can fix. –  desgua May 5 '11 at 17:59
    
Second attempt doesn't do the trick either. Even without your modification there is a gnome panel loaded (i see the process in the text console). Even the unity panel service loads when I use the Ubuntu profile. I get the impression that something doesn't finish loading (in both Ubuntu and classic with effects) because if I move the mouse over to where the toolbar would be I get the working mouse. I just tried entering Ubuntu Classic (without effects) and it worked. –  Octav S May 5 '11 at 19:44
    
Th ething is with fglrx I get n error when trying to load unity, saying to use classic because of lack of hardware. But with the radeon driver I don't get that error, they seem to start loading but never end. They just hang. –  Octav S May 5 '11 at 19:46
    
I will look toward a solution and post here if I find something. –  desgua May 5 '11 at 22:03
show 1 more comment

the same thing happened to me and i think i have your solution (or at least this is what work for me)

boot up in Ubuntu classi**c and go to **system - administration - synaptic package manager remove anything that has to do with compiz (or anything that has compiz in the name)

now restart your computer and boot up in Ubuntu and press ctrl alt t and your terminal should come up type in this line sudo apt-get install compiz then press enter after that type in this line sudo apt-get install unity press enter then sudo apt-get upgrade unity

after its done restart your computer and boot in to ubuntu and bam everything is back

share|improve this answer
    
Sorry, that did not work, i don't think that the packages were corrupted / not correctly installed. I had the exact same "freeze". Thanx anyway. –  Octav S May 7 '11 at 17:43
add comment

It happened to me, you can do this to fix:

Go to Ubuntu Classic (without effects), start CCSM and enable Gnome Plugin or Unity Plugin.

Seems that Compiz has some problem to use them both, because the plugins seem to conflict.

share|improve this answer
    
Sorry, but in my CCSM only Gnome Plugin is enabled, Unity Plugin is not enabled. I tried "compiz --replace" and got to the freezing part. I also disabled Gnome Plugin and tried unity and got to the same old "freezing". Thanx anyway. –  Octav S May 7 '11 at 18:06
add comment

Change the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub in:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1 pci=nomsi"

Run update-grub and reboot

The pci=nomsi did the trick for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.