Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Chromium “Show in Folder” opens in text editor

(Using ubuntu 11.04)

I tried to open a torrent file in chrome, and it asked for my default application, so I clicked Transmission, and then I got an error: "Failed to execute default file manager, Failed to execute child process "transmission" (No such file or directory)."

Now if I click on any shortcut on the unity bar, such as the trash folder or the icon for my portable hard drive, I get this error, as well as with any download or folder from chrome or firefox. I can't seem to figure out how to fix this, as there seems to be no easy way to do it.

share|improve this question

marked as duplicate by Jorge Castro, Oli Jul 26 '11 at 13:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers 4

I hope I can answer this with an answer I posted a while back here Chromium "Show in Folder" opens in text editor (That would make this a duplicate so it might get closed ;) )

In ~/.local/share/applications/mimeapps.list there is a list of files to be opend by an application. Have a look with more ~/.local/share/applications/mimeapps.list and check if you can find something weird here. You can use vi or gedit to edit this file.

But there is also a command mimeopen that allows you to alter what program should open what file (and that updates the file I mentioned before). It will 'guess' what would be the most logical option based on the file you feed it.

mimeopen -d /home/{your_name}/Documents
Please choose a default application for files of type inode/directory

    1) Open Folder  (nautilus-folder-handler)
    2) Other...

mimeopen -d \[Mazui\]_Ore_No_Imouto_-_14_\[SD\]\[7EA51F50\].mkv 
Please choose a default application for files of type video/x-matroska

    1) Enqueue in SMPlayer  (smplayer_enqueue)
    2) Movie Player  (totem)
    3) SMPlayer  (smplayer)
    4) Banshee  (banshee)
    5) VLC media player  (vlc)
    6) Other...

Same works for a torrent file and any other file.

Maybe you already know this but if you can not get to command line use control-alt-f1 and log in with your sudo user account and password. control-alt-f7 gets you back to your desktop.

share|improve this answer

Delete the file: ~/.local/share/mime/mime.cache, and it should reset your file manager.

share|improve this answer
    
It seems there is no ../share/mime, however there is ~/.local/share/applications/mimeinfo.cache and /mimeapps.list, should I remove one of those? –  user16171 May 5 '11 at 17:55
2  
Do not delete it please. When someone talks about a file do locate mime.cache (change mime.cache to what you want to search) and you will get the location: /usr/share/mime/mime.cache You can rename this to mime.cache.old and then remove mime.cache. If things go wild due to deleting something you can use the *old version back to the original! (always try to use the safest option ;) ) –  Rinzwind May 5 '11 at 17:58
    
@Rinzwind: good catch, I only just saw his comment :)! –  RolandiXor May 5 '11 at 18:00
    
I've deleted it (after backing it up) and restarted my pc, but the problem is still there (seems nothing has changed) –  user16171 May 5 '11 at 18:04
    
I messed up too! I do not have a mimelist.cache. That would suggest I have nothing there yet (due to never changing a mimetype!) so ~/.local/share/applications/mimeinfo.cache should be safe to remove and my other comment was not accurate! :) –  Rinzwind May 5 '11 at 18:06

Try to change it back with gconf:

gconftool --set "/desktop/gnome/applications/component_viewer/exec" --type string "nautilus %s"

Note: you should replace nautilus with na exec name of you preferred file manager.

share|improve this answer

I had the same problem. Open up a terminal and type:

gksudo nautilus /usr/share/applications

Find "File Manager" and right-click on it. Choose "Properties." Under the "Basic" tab, change "Command" to "nautilus".

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.