Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I need Adobe Air for an important software that is only delivered via that platform, but it'll be used on a box that has Ubuntu x64. So there's no way around that.

From my research, the consensus is that:

  • Adobe no longer supports Linux as of v2.6
  • The final v2.6 *.bin file can be installed, but needs 32-bit libraries
  • Since ia32libs is deprecated, one must do some hacking to get the whole thing to work

So, I've been following along here, which seems to me to give the clearest directions: http://www.randomhacks.co.uk/package-ia32-libs-gtk-has-no-installation-candidate-ubuntu-13-10/

I also found a .deb somewhere, but run into essentially the same problem, which I will describe below.

# ./AdobeAIRInstaller.bin 
/tmp/air.otFPvM/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

I cannot get the 32-bit libraries required for the solution, and I don't know how to acquire them. They are needed for the Adobe Air installer to proceed properly. I need to be able to execute this command to get the .deb to work, which should also give me what I need for the normal installer as well:

sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386

However, doing so yields a mystifying error about not being able to find said packages:

$ sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgtk2.0-0
E: Couldn't find any package by regex 'libgtk2.0-0'
E: Unable to locate package libnss3-1d
E: Unable to locate package libnspr4-0d
E: Unable to locate package libxml2
E: Unable to locate package libxslt1.1
E: Couldn't find any package by regex 'libxslt1.1'

I apologize if this isn't very clear, I've been working at this most of the day. Basically, I have two possible solutions -- the .bin installer or the .deb file -- but I can't get either to work because of the unavailable 32-bit libraries.

I'm afraid this is beyond my skills, and I would kindly ask your help in solving this problem. Feel free to ask for clarification.

Cheers,

Preston

share|improve this question

marked as duplicate by karel, Eliah Kagan, minerz029, falconer, BuZZ-dEE Jan 12 at 13:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

Just update the repositories and then try to install the packages,

sudo apt-get update
sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 lib32z1 lib32ncurses5 lib32bz2-1.0
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.