Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i think i really need your assistance in this.I've installed ubuntu 10.10 and this mac theme and so far it works fine. This morning i upgraded to 11.04 and it also went well. i just realise some of the effects were gone. so i open compizconfig settings manager, i've tried to enable the destop cube and the expo and it prompted me of desabling somethings here and there.
honestly i went fast couldn't undo what i've done and i realize the new application launcher and the system bar weren't showing properly, so i decided to restart my machine.After that 'bummer', nothing were like system bar, no application launcher, not menu bar for any of my applications not even for the console. How i'm going to solve this one this time.

thanks for reading this and specially for helping out.

share|improve this question
up vote 6 down vote accepted

Macbuntu, according to its own site, is not compatible with Unity. After you downloaded it, you extracted it into a directory. If you've deleted that directory, re-download and re-extract.

  • Open a terminal, run cd /path/to/the/macbuntu/folder/
  • In that same terminal, run ./

This should remove Macbuntu. If it does not, please read its README and/or contact the developer for support.

Now we need to fix Unity.

  • Go to the terminal and type gksu synaptic. You will be prompted for your password.
  • Type Unity in the quick filter bar.

enter image description here

  • Right click on the Unity package (in the list in the middle of the window), and choose Mark for Reinstallation.

enter image description here

  • Click the apply button, and wait for the changes to finish.

enter image description here

  • Close Synaptic, and the terminal. You may need to log out and back in to see the changes.
share|improve this answer
Hi thanks for the reply. the "./ force" command successfully uninstall Macbuntu, i've installed the unity but after a restart still system bar, and unity are not back :( – black sensei May 5 '11 at 17:27
Could you try "unity --reset" from the command line? – Kevin May 5 '11 at 17:34
hello it came but outputs this and it's seems like it's running from the console since it doesn't return the prompt – black sensei May 5 '11 at 17:52
Press <Ctrl>+Z in the console, then type "bg" then "disown". Note that your window system might break when you press <Ctrl>+Z, so read the whole answer before you start! – Kevin May 5 '11 at 17:54
You're probably good. I think the --reset flag caused it to fix your configuration. It should work. – Kevin May 5 '11 at 18:12

the same thing happened to me and i think i have your solution (or at least this is what work for me)

boot up in Ubuntu classic and go to system - administration - synaptic package manager remove anything that has to do with compiz (or anything that has compiz in the name)

now restart your computer and boot up in Ubuntu and press ctrl alt t and your terminal should come up type in this line sudo apt-get install compiz then press enter after that type in this line sudo apt-get install unity press enter then sudo apt-get upgrade unity

after its done restart your computer and boot in to ubuntu and bam everything is back

share|improve this answer
when you did so, did you have the expo and the cube desktop working? – black sensei May 9 '11 at 7:47

It sounds to me like a compiz problem, though I may be wrong. Try pressing Alt+F2 to open the quick launcher. From here you can start programs, like the compiz settings manager. To do this, try typing "ccsm" into the launcher. There, you can turn off the cube again. Hope this works for you.

edit: If you can open the settings manager, you may want to turn off the Unity-Plugin, and then on again.

If you can't use Alt+F2, maybe you can log into a different session (Ubuntu Classic (no effects)) at login and correct it like this.

share|improve this answer
Thanks for the reply.i still have the dock "docky" and i've turned off everything under desktop submenu and it still seems not working even after restart. – black sensei May 5 '11 at 17:00
Just tried it myself, the cube seems to collide with desktop wall. Can you turn that and unity plugin on again? does it help? – woodfrog May 5 '11 at 17:04
thank you for your time. Kevin's approach worked for me.thanks – black sensei May 9 '11 at 7:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.