Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Natty and am getting used to the new interface. I depend on blue proximity for locking my desktop when I leave my office. After upgrade I no longer see the icon in the panel area. I tested and It is working but I have no idea how to configure it now. How do I get the icon back and configure it?

share|improve this question
    
(To whoever tries to answer this, this looks like a whitelist question) –  Jorge Castro May 5 '11 at 16:02
1  
@Jorge What is a whitelist question? –  Andrew Redd May 5 '11 at 16:10
    
See here (basically the same thing binarylife says): askubuntu.com/questions/30742/… –  Jorge Castro May 5 '11 at 16:12

2 Answers 2

up vote 4 down vote accepted

Your problem is that the program doesn't show up in the notification area. Ubuntu natty has a whitelist for only some programs to show up. But there's an easy way to either re-enable the Systray for all applications or to whitelist a few applications you can't live without.

To enable the Notification Area (Systray) for all applications, run the following command in a terminal:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

You can only whitelist a certain application if you want, by using the following command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'YOUR_APPLICATION']"

The above command includes the already whitelisted (by default) applications so you should replace "YOUR_APPLICATION" with the application you want to whitelist.

For blueproximity:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'proximity']"

In Ubuntu 13.04 the systray-whitelist hard-coded so the above configuration change no longer works. Use this https://bugs.launchpad.net/unity/+bug/974480/comments/42 ppa and follow the instructions to enable the whitelist and set it to "['all']"

share|improve this answer
    
'all' was the only thing that worked. –  Andrew Redd May 5 '11 at 17:15
    
Whitelisting "blueproximity" doesn't work and I don't want to whitelist all applications. Any other ideas? –  Alin Andrei May 24 '11 at 9:22
    
@Alin Andrei: Yes There was an error in the code; 'blueproximity' should be replaced with 'proximity' . Thanks for reminding me to fix this:). –  Binarylife May 24 '11 at 15:12

The accepted answer will not work for version 13.04 and newer, because that whitelist was removed from Ubuntu.

However there is a patch for blueproximity to make it work with unity's app indicator.

You can apply the patch as follows:

wget http://sourceforge.net/p/blueproximity/patches/_discuss/thread/3d5eb592/7e50/attachment/proximity.patch
sudo patch /usr/share/blueproximity/proximity.py < proximity.patch
sudo apt-get install python-appindicator

That works in 13.10 and 14.04. Haven't tested other versions. I see no reason why wouldn't work in other versions though. I would also recommend this over the whitelist solution.

Hopefully that patch will be integrated into newer version of blue proximity.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.