Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the latest version of ubuntu on my sony vaio e series machine which came with win8 64 bit pre-installed.I recently updated to 8.1 though.

Since the machine comes with secure boot and UEFI, I disabled secure boot, changed UEFI to legacy mode. To install ubuntu I used a live usb. I created a partition for installing ubuntu, formatted it to ext4, created another tiny partition to use it as bios code area, installed ubuntu on the partition ( the first one of course) with mount point / .

After installation was successful I restarted the machine. It booted into live usb again. I installed boot repair, ran it using the recommended settings. After the repair was successful it told me not to forget to change bios boot on sda3/efi/ubuntu/shimx64.efi. Now I don't now exactly what that means. So I rebooted the system, went into bios, enabled secure boot and boot mode to UEFI again (opposed to legacy). But now when I boot the system after detaching the live usb, it shows a message that operating system is unavailable. I disabled secure boot and changed to legacy mode again. Now the screen get's stuck in the initial vaio logo.

Now I think the issue was with not changing bios boot on shimx64.efi. But being this my first time with linux, I don't know what that means. Also it might be something else?I tried searching for a solution but was unable to find anything useful.I have now restored my efi files with boot repair and am able to boot into windows.

But couldn't get ubuntu to load anyways :( here is pastebin: paste.ubuntu.com/6732864/

share|improve this question
add comment

1 Answer 1

Your first mistake was installing Linux in BIOS/CSM/legacy mode. The advice to do this is being spread wide and far, but it's BAD ADVICE!!!! At best it's a necessary but temporary workaround on a handful of very buggy computers, or can be a way to simplify a Linux-only setup; but when dual-booting with Windows 8, it's more likely to create extra work, and can lead to problems like the one you're experiencing.

What I recommend you do is the following:

  1. Update your computer's firmware to the latest version. This sometimes fixes bugs that can contribute to the sort of problem you've got. (If you can't update because the only way to do so requires booting Windows or because an update isn't available, you'll have to skip this step.)
  2. Using any computer that works, download and prepare a USB flash drive or CD-R with my rEFInd boot manager. (That page has download links for ready-made images for both types of media.)
  3. Enter your firmware setup utility and ensure that:
    • Secure Boot is disabled
    • BIOS/CSM/legacy mode is disabled (and EFI/UEFI support is enabled, if your firmware phrases it that way)
  4. Boot using the rEFInd medium. It should present various options for booting both Windows and Linux. Test them all and ensure that you can boot both OSes.
  5. If you can boot both OSes from rEFInd, install the Debian package version in Ubuntu.

With any luck, you'll now be able to boot both OSes via rEFInd, without using the CD-R or USB flash drive. If the firmware continues to insist that the computer isn't bootable, though, post back with details. It may be possible to work around the problem in one way or another, but if the above procedure doesn't work, you're almost certainly into bad-firmware-bug territory, which can be difficult to traverse. If the computer is new, I'd seriously consider replacing it in that case.

Even if the above procedure works, you may end up with duplicate boot entries. Those can be dealt with in various ways:

  • You can use Boot Repair's Advanced options screen to undo its backup/rename operation, which causes a duplicate Windows entry, one of which boots to GRUB.
  • If you're sure you don't want to use a boot loader ever again, you can delete it from /boot/efi/EFI/{somename}.
  • If you want to unclutter an entry but keep the boot loader itself available, you can use the dont_scan_volumes, dont_scan_dirs, or dont_scan_files option in /boot/efi/EFI/refind/refind.conf to hide a partition, directory, or file.

Note that you're likely to have at least three Linux entries: One will launch GRUB and two others will launch Linux directly. It's best to keep them all around because they can provide alternative ways of booting in case one fails in the future. The direct-boot entries each boots its own kernel, so you can choose which kernel to boot (much as you can from GRUB).

share|improve this answer
    
Actually I can boot into windows after restoring the efi backups created by boot repair within live usb. As the situation was, I couldn't make the live usb to boot if I only disabled secure boot. I had to change boot mode to Legacy also. I tried multiple times but if boot mode was set to UEFI it would just boot into windows no matter the boot order. I am downloading the latest version of vaio care, after that I would see if there is a newer version of the firmware. Also I will try rEFInd after that. I will come back with the results. –  prithul Jan 12 at 16:42
    
This other recent question reveals a Sony with a buggy firmware that insists on booting Windows. There are ugly hackish ways around such bugs -- namely, to rename the Windows boot loader and put whatever you like in its place. IMHO, though, it's better to return the computer for a refund if you've got this problem. That's the ONLY action that will get the manufacturer's attention. –  Rod Smith Jan 12 at 18:29
    
Unable to solve the problem I am now booting ubuntu on virtualbox with guest addition. Once I get familiar with ubuntu I might take another try or just install it on my desktop. –  prithul Jan 14 at 12:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.