Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Surface Pro insists on booting into the EFI settings menu (black screen, white text, with only the "secure boot" and "tpm options) after installing 13.10 no matter what I do, and it seems like I must've tried about a hundred different things for several days straight now.

I have waffled back and forth between restoring Windows 8 and Ubuntu on this machine, but now I am just wanting to wipe out any trace of Windows and run Ubuntu solely, and natively. Interestingly, Ubuntu installed fine the first time around but after waffling back to Windows 8 the first time, Ubuntu will not install again or more accurately, will not boot after installing.

I am installing Ubuntu 13.10 64-bit desktop edition from thumb bootable thumbdrive which I created using unetbootin.

I definitely definitely have Secure Boot disabled. I can boot to the "live" usb stick just fine, and the installation appears to proceed properly all the way to the point where am restarting and am prompted to remove the bootable media.

I have gone so far as to delete all partitions from Surface's internal SSD and even to create an "msdos" partition table (as gparted calls it, I'm assuming is synonymous with "mbr) just to ensure that no GPT relics remain. The ubuntu installer seems to recreate partition table as gpt with individual partitions as it sees fit.

Here is my boot-repair paste: http://paste.ubuntu.com/6731471/

In this latest attempt, I've tried to create an encrypted main partition, but I've tried both ways a total of 20-30 times and have the same problem regardless.

Also, the boot-repair paste shows that " => No boot loader is installed in the MBR of /dev/sda" but in this latest iteration boot-repair's advanced options do not show the option to repair the boot sector or mbr. I don't know why. I have seen those options in the past but using them did not fix the problem. The Surface just boots back into the EFI options black and white screen no matter what.

enter image description here

Also I might add that I've tried boot-repair's "recommended repair" about a dozen times, but to no avail.

Any help anyone could provide is most appreciated. Please don't send me back to Windows land! I would much rather get Ubuntu running natively rather than within an VM.

share|improve this question
    
Have you disabled TPM and SecureBoot from BIOS then try re-installing ? –  Tommy Aria Pradana Jan 11 at 9:47
    
Yes. TPM and Secureboot are completely and utterly disabled. –  ardave Jan 11 at 9:50
    
When you installing your Ubuntu are you choose Something Else or Install Ubuntu ? –  Tommy Aria Pradana Jan 11 at 10:02
    
No, I'm using the top-most option which causes the installer to automatically partition the drive. I don't remember the exact wording, but "Install Ubuntu" sounds reasonable. –  ardave Jan 11 at 10:07
    
I suggest to try the Something Else Options to.Since you can configure partitions and bootlaoder location. –  Tommy Aria Pradana Jan 11 at 10:15

1 Answer 1

I just figured this out after about 4 days of solid pounding on the problem. I had some stale boot configuration data records that were being persisted in nvram of the machine and were therefore surviving my most thorough attempts at wiping out the SSD to a clean slate.

Lots of documentation about BCD is ambiguous as to whether the data is stored in the EFI partition or in nvram on the machine. Perhaps the storage location is machine-specific, but several times I deleted all of the partitions from this Surface's SSD AND the partition table itself, but this did not fix the issue.

I finally reinstalled and booted into Windows 8 and tinkered around with bcdedit.exe, which is a pretty crude tool, before reading that EasyBCD has a free license for individuals. Using it was a cinch; I just deleted all BCD records for both Windows and Ubuntu, then rebooted and ran the Ubuntu installer again and voila!!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.