Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

The wireless connection in my house unfortunately often disappears, requiring a wireless router reboot.

Making this worse is that my ubuntu media pc, does not automatically reconnect to the wireless network when it's been gone, and then comes up about a minute later. The network in question is setup as "connect automatically" in the network settings.

If I manually select my wireless network, using the wireless icon in the topright of my screen, everything works fine, until the next time that wireless goes down.

I'm looking for a way so I don't have to remember to do this manually all the time.

share|improve this question
I have the exact same problem. I'd be satisfied with a solution that used, e.g. a cron script every 5 minutes asking for Network Manager to reconnect, if it's not connected already. –  Marius Gedminas Sep 11 '10 at 21:57
@Marius do you have such a script? –  Oli Sep 12 '10 at 9:21
Please add some hardware information to your question. –  Jorge Castro Sep 16 '10 at 17:49
@Oli: sadly, no. –  Marius Gedminas Sep 28 '10 at 3:36

5 Answers 5

This seems to be posted all over the net with no good solutions. I guess the best fix/workaround is to make it check for internet connectivity and if it is not there then reconnect. I did this via a ping test to google.com and then I simply made it restart networking. Code is not tested (the restart part and the cron part, if statement tested), so I'll just wait for it to disconnect at some point. I have an Ubuntu Server 12.10, so no GUI, and is a pain to connect monitor and keyboard every time the wireless stuffs up.

Cron part done via webmin so Idk much about it. Script is as follows:

# edited by dim_voly for networking restart on no pingback every 5 mins

# Name of File: networkingCron
# Purpose: to check if the internet is up (via ping test to google) and if not, restart networking service
# this script is invoked via cron, ideally every 5 mins.

#check if there is internet via ping test
if ! [ "`ping -c 1 google.com`" ]; then #if ping exits nonzero...
   sudo service networking restart #restart the whole thing
   echo Networking service restarted due to no ping response from google.com

echo Script 'networkingCron' completed, if no message above then there was no network restart.

# dunno how to restart the wifi only since that is the only active connection that server uses.

# also I don't think those echos go anywhere

Make sure to run as root and make sure the script has execute (u+x) permissions.


share|improve this answer

I had a similar problem with my laptop's Intel Wireless WiFi 5100 half height card and the driver iwlagn driver. This problem is a known issue with the iwlagn driver, and the best workaround is to disable 802.11n on the card.

To disable 802.11n on this card create/edit your /etc/modprobe.d/options.conf file:

sudo -H gedit /etc/modprobe.d/options.conf

And add the following to it.

options iwlagn 11n_disable=1 11n_disable50=1
share|improve this answer

You might want to have a look at using wpa_supplicant instead of network-manager, but that doesn't really matter when on a media-center. wpa_supplicant isn't as flexible as network-manager but afaik it doesn't give up after trying three times. have a look at this answer.

share|improve this answer

Just create a new file vi /root/checkwanup and add this content:

wlan=`/sbin/ifconfig wlan0 | grep inet\ addr | wc -l`    
if [ $wlan -eq 0 ]; then    
    /sbin/ifdown wlan0 && /sbin/ifup wlan0
    echo interface is up    

Then chmod 555 /root/checkwanup and add it to your crontab:

crontab -e
*/15 * * * * /bin/bash /root/checkwanup

Source: http://sirlagz.net/2013/01/10/script-wifi-checker-script/

share|improve this answer

More modern version of @DougD script

wlan=$(/sbin/ifconfig wlan0 | grep inet\ addr -c)
if [ "$wlan" -eq 0 ]; then    
    /sbin/ifdown wlan0 && /sbin/ifup wlan0
    echo interface is up    
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.