Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after instlling samba4 with the last message to be successful, i've tried to provision but got the following errors:

ldb: module schema_load intialization failed: no such object
ldb:module rootdse intitialization failed: no such object
ldb: module samba_dsdb initilization failed: no such object
ldb: unable to load modules for /usr/local/samba/private/sam.ldb/ null smbd-connect failed ufs.connect failed
Error class samba provision provisionerrror provision failed your file system or build does not support posix ACLs, which s3fs reqiores - try mounting file system acl.

file /usr/local/samba/lib/python2.7/site-package/samba/netcmd/domain.py line 427 in run

I've tried the provision many times. is there any way to fix this samba4 installation? thank you

share|improve this question

1 Answer 1

You need to install attr and acl. Also your shares mount needs to have xatrr and acl declarations in fstab.

also krb5-user needs to be installed.

Said this before I use the sernet enterprise samba repo's as they are more up to date.

Also a btrfs backend for samba shares allows you to utilise server side copies which is essential if you copy across network drives faster than working on a local machine.

I have some ready to roll virtualbox ova's 12.04 and samba 4.1.6 on http://sourceforge.net/projects/samba4all/files/4.1.6/

documentation and a collection of good links there as well

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.