Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

the function "print to file" doesn't have any output. I want to print for example a web page just as pdf. when the print dialogue is open, i select "print to file". a progress bar is displayed and finishes, but a pdf can't be found anywhere. my file manager is nautilus.

share|improve this question
    
Try running sudo updatedb and then locate <FILENAME>. It will update the file database and then search your PC. Please respond with what you get. –  RPi Awesomeness Jan 10 at 15:01
    
acutally, there is no output, locate doesn't find anything. –  Fungi cerebrum Jan 10 at 18:12

1 Answer 1

up vote 1 down vote accepted

This could be more a workaround than an answer, but I think it is worth knowing so I post it here.

Notice I know that the "official" point of view is that the PDF virtual printer is not needed any more thanks to the "print to file" option. Nevertheless I still like the simmetry of having the virtual printer --- you can set it as your default printer, use it with old programs that do not use the unified printing interface, etc. YMMV.

I often find that the option "print to file"can be quite flaky. The best method to print to PDF in my opinion is the following:

1) install a virtual PDF printer:

sudo apt-get install cups-pdf

2) Now you have a printer called "PDF" that you can choose.

3) Printing in that printer will result in a .pdf file in the folder PDF under your home directory. You may need to create it with mkdir $HOME/PDF (it's case-sensitive).

Advantages:

1) This is seen as a normal printer. ALL programs that can print can print to it, so you do not need the "print to file" option. For example you can easily do

ls -l | lpr -pPDF 

and have a pdf file with the output of your command.

Caveats:

1) Move files from there because if you print a file multiple times the last version will overwrite previous ones. This is avoidable with a little configuration file editing --- just open the file /etc/cups/cups-pdf.conf, it is very well documented, and search for the line #Label 0 and change it into Label 1 (or 2 if it suits you better).

2) you do not decide the file name, and you need to move it where you want it. (It seems it can be solved, but it's quite convoluted).

3) Sometime upgrading the system disables the printer. Don't know why. Reinstalling cups-pdf solves the problem.

4) Color management and quality control is tricky.

share|improve this answer
    
it worked with cups, thx for the comprehensive answer! i tried to change the standard path in the configuration file in /etc/cups/cups-pdf.conf but it didn't work. well, is not such a big problem, would just be nice to change it. –  Fungi cerebrum Jan 10 at 18:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.