Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I was trying to install a driver for a UVC camera, I got an error:

/usr/bin/ld: cannot find -lasound
/usr/bin/ld: cannot find /lib/libpthread.so.0 inside 
/usr/bin/ld: cannot find /usr/lib/libpthread_nonshared.a inside 
collect2: ld returned 1 exit status
make[4]: *** [capture_mux] Error 1
make[4]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/64380/mxuvc/examples'
make[3]: *** [build_bin] Error 2
make[3]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/64380/mxuvc'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/64380/mxuvc'
make[1]: *** [mxuvc/all] Error 2
make[1]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/64380'
make: *** [buildall] Error 2

My first step was:

ubuntu@ubuntu:~/me4_x86-tot-44324/me4_x86-sdk/sw$ make defconfig PRODUCT_TYPE=me4_x86
Installing Package ------------ > kernel-devel 
No package with kernel-devel package present in repositories
Installing Package ------------ > kernel 
No package with kernel package present in repositories
Installing Package ------------ > libdaemon-devel 
No package with libdaemon-devel package present in repositories
Installing Package ------------ > expat-devel 
No package with expat-devel package present in repositories
Installing Package ------------ > avahi-devel 
No package with avahi-devel package present in repositories
Installing Package ------------ > fcgi-devel 
No package with fcgi-devel package present in repositories
Installing Package ------------ > lighttpd 
No package with lighttpd package present in repositories
Installing Package ------------ > alsa-lib-devel 
No package with alsa-lib-devel package present in repositories
Installing Package ------------ > alsa-utils 
No package with alsa-utils package present in repositories
Installing Package ------------ > libcurl-devel
No package with libcurl-devel package present in repositories
Installing Package ------------ > udev 
No package with udev package present in repositories
Installing Package ------------ > libusb1-devel 
No package with libusb1-devel package present in repositories
Installing Package ------------ > libusb1-static 
No package with libusb1-static package present in repositories
Installing Package ------------ > glibc-static 
No package with glibc-static package present in repositories
Installing Package ------------ > gcc 
No package with gcc package present in repositories
Installing Package ------------ > gcc-c++ 
No package with gcc-c++ package present in repositories
Installing Package ------------ > doxygen 
No package with doxygen package present in repositories
Installing Package ------------ > openssl-devel 
No package with openssl-devel package present in repositories
Setting default config for me4_x86
make[1]: Entering directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/host_sdk'
make[1]: Nothing to be done for `defconfig'.
make[1]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/host_sdk'
make[1]: Entering directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/buildroot'
mkdir -p /home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/buildroot/output/build/buildroot-config
#
# configuration written to /home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/buildroot/.config
#
make[1]: Leaving directory `/home/ubuntu/me4_x86-tot-44324/me4_x86-sdk/sw/buildroot'
share|improve this question
    
What was it you was trying to install? –  blade19899 Jan 10 at 11:33
    
It was an driver for uvc-camera –  user234110 Jan 10 at 11:37
    
Could you provide a link to the driver, the type of system you are using(32bit/64bit) and the details about the camera. at best you need to install the 32bit libraries, but, thats if your lucky. If your not lucky you will enter dependencies hell. Note preferably edit your question and add details –  blade19899 Jan 10 at 11:39
    
I cant give you a link for this and the name of the camera...Im using 32bit system –  user234110 Jan 10 at 11:45
    
I only need the libralys... I think so –  user234110 Jan 10 at 11:49
show 24 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.