Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Given the following /var/log/Xorg.0.log, which graphics driver is the X server currently using? This log is too confusing for me to parse (I had to snip hopefully irrelevant parts to be able to post the question):

[    42.851] 
X.Org X Server 1.11.3
Release Date: 2011-12-16
[    42.851] X Protocol Version 11, Revision 0
[    42.851] Build Operating System: Linux 2.6.42-37-generic i686 Ubuntu
[    42.851] Current Operating System: Linux malou-laptop 3.2.0-57-generic #87-Ubuntu SMP Tue Nov 12 21:38:12 UTC 2013 i686
[    42.851] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-57-generic root=UUID=4a8098b3-159d-490a-8216-fe5649d4c129 ro quiet splash
[    42.851] Build Date: 16 October 2013  04:45:22PM
[    42.851] xorg-server 2:1.11.4-0ubuntu10.14 (For technical support please see http://www.ubuntu.com/support) 
[    42.851] Current version of pixman: 0.24.4
[    42.851]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    42.851] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    42.851] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 10 10:00:25 2014
[    42.947] (==) Using config file: "/etc/X11/xorg.conf"
[    42.947] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    42.953] (==) No Layout section.  Using the first Screen section.
[    42.953] (==) No screen section available. Using defaults.
[    42.953] (**) |-->Screen "Default Screen Section" (0)
[    42.953] (**) |   |-->Monitor "<default monitor>"
[    42.953] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[    42.953] (**) |   |-->Device "Default Device"
[    42.953] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    42.953] (==) Automatically adding devices
[    42.953] (==) Automatically enabling devices
[    42.953] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    42.953]    Entry deleted from font path.
[    42.953] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
[    42.953] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[    42.953] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    42.953] (II) Loader magic: 0x7b35a0
[    42.953] (II) Module ABI versions:
[    42.953]    X.Org ANSI C Emulation: 0.4
[    42.953]    X.Org Video Driver: 11.0
[    42.953]    X.Org XInput driver : 16.0
[    42.953]    X.Org Server Extension : 6.0
[    42.955] (--) PCI:*(0:1:0:0) 10de:0429:17aa:20d8 rev 161, Mem @ 0xd2000000/16777216, 0xe0000000/268435456, 0xd0000000/33554432, I/O @ 0x00002000/128
[    42.955] (II) Open ACPI successful (/var/run/acpid.socket)
[    42.955] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    42.955] (II) "extmod" will be loaded by default.
[    42.955] (II) "dbe" will be loaded by default.
[    42.955] (II) "glx" will be loaded by default.
[    42.955] (II) "record" will be loaded by default.
[    42.955] (II) "dri" will be loaded by default.
[    42.955] (II) "dri2" will be loaded by default.
[    42.955] (II) LoadModule: "extmod"
[    42.982] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[    42.982] (II) Module extmod: vendor="X.Org Foundation"
[    42.982]    compiled for 1.11.3, module version = 1.0.0
[    42.982]    Module class: X.Org Server Extension
[    42.982]    ABI class: X.Org Server Extension, version 6.0
[    42.982] (II) Loading extension MIT-SCREEN-SAVER
[    42.982] (II) Loading extension XFree86-VidModeExtension
[    42.982] (II) Loading extension XFree86-DGA
[    42.982] (II) Loading extension DPMS
[    42.982] (II) Loading extension XVideo
[    42.982] (II) Loading extension XVideo-MotionCompensation
[    42.982] (II) Loading extension X-Resource
[    42.982] (II) LoadModule: "dbe"
[    42.982] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[    42.983] (II) Module dbe: vendor="X.Org Foundation"
[    42.983]    compiled for 1.11.3, module version = 1.0.0
[    42.983]    Module class: X.Org Server Extension
[    42.983]    ABI class: X.Org Server Extension, version 6.0
[    42.983] (II) Loading extension DOUBLE-BUFFER
[    42.983] (II) LoadModule: "glx"
[    42.983] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/libglx.so
[    50.773] (II) Module glx: vendor="NVIDIA Corporation"
[    50.773]    compiled for 4.0.2, module version = 1.0.0
[    50.773]    Module class: X.Org Server Extension
[    50.773] (II) NVIDIA GLX Module  331.20  Wed Oct 30 17:53:40 PDT 2013
[    50.773] (II) Loading extension GLX
[    50.773] (II) LoadModule: "record"
[    50.774] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[    51.245] (II) Module record: vendor="X.Org Foundation"
[    51.245]    compiled for 1.11.3, module version = 1.13.0
[    51.245]    Module class: X.Org Server Extension
[    51.245]    ABI class: X.Org Server Extension, version 6.0
[    51.245] (II) Loading extension RECORD
[    51.245] (II) LoadModule: "dri"
[    51.246] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[    51.246] (II) Module dri: vendor="X.Org Foundation"
[    51.246]    compiled for 1.11.3, module version = 1.0.0
[    51.246]    ABI class: X.Org Server Extension, version 6.0
[    51.246] (II) Loading extension XFree86-DRI
[    51.246] (II) LoadModule: "dri2"
[    51.246] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[    51.246] (II) Module dri2: vendor="X.Org Foundation"
[    51.246]    compiled for 1.11.3, module version = 1.2.0
[    51.246]    ABI class: X.Org Server Extension, version 6.0
[    51.246] (II) Loading extension DRI2
[    51.246] (==) Matched nvidia as autoconfigured driver 0
[    51.246] (==) Matched nouveau as autoconfigured driver 1
[    51.246] (==) Matched nv as autoconfigured driver 2
[    51.246] (==) Matched vesa as autoconfigured driver 3
[    51.246] (==) Matched fbdev as autoconfigured driver 4
[    51.246] (==) Assigned the driver to the xf86ConfigLayout
[    51.246] (II) LoadModule: "nvidia"
[    51.246] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    51.669] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.669]    compiled for 4.0.2, module version = 1.0.0
[    51.669]    Module class: X.Org Video Driver
[    51.687] (II) LoadModule: "nouveau"
[    51.688] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    51.688] (II) Module nouveau: vendor="X.Org Foundation"
[    51.688]    compiled for 1.11.3, module version = 0.0.16
[    51.688]    Module class: X.Org Video Driver
[    51.688]    ABI class: X.Org Video Driver, version 11.0
[    51.688] (II) LoadModule: "nv"
[    51.714] (WW) Warning, couldn't open module nv
[    51.714] (II) UnloadModule: "nv"
[    51.714] (II) Unloading nv
[    51.714] (EE) Failed to load module "nv" (module does not exist, 0)
[    51.714] (II) LoadModule: "vesa"
[    51.714] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    51.715] (II) Module vesa: vendor="X.Org Foundation"
[    51.715]    compiled for 1.11.3, module version = 2.3.0
[    51.715]    Module class: X.Org Video Driver
[    51.715]    ABI class: X.Org Video Driver, version 11.0
[    51.715] (II) LoadModule: "fbdev"
[    51.715] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    51.715] (II) Module fbdev: vendor="X.Org Foundation"
[    51.715]    compiled for 1.11.3, module version = 0.4.2
[    51.715]    ABI class: X.Org Video Driver, version 11.0
[    51.715] (==) Matched nvidia as autoconfigured driver 0
[    51.715] (==) Matched nouveau as autoconfigured driver 1
[    51.715] (==) Matched nv as autoconfigured driver 2
[    51.715] (==) Matched vesa as autoconfigured driver 3
[    51.715] (==) Matched fbdev as autoconfigured driver 4
[    51.715] (==) Assigned the driver to the xf86ConfigLayout
[    51.715] (II) LoadModule: "nvidia"
[    51.715] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    51.715] (II) Module nvidia: vendor="NVIDIA Corporation"
[    51.990]    compiled for 4.0.2, module version = 1.0.0
[    51.990]    Module class: X.Org Video Driver
[    51.990] (II) UnloadModule: "nvidia"
[    51.990] (II) Unloading nvidia
[    51.990] (II) Failed to load module "nvidia" (already loaded, 7838747)
[    51.990] (II) LoadModule: "nouveau"
[    51.990] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    51.990] (II) Module nouveau: vendor="X.Org Foundation"
[    51.990]    compiled for 1.11.3, module version = 0.0.16
[    51.990]    Module class: X.Org Video Driver
[    51.990]    ABI class: X.Org Video Driver, version 11.0
[    51.991] (II) UnloadModule: "nouveau"
[    51.991] (II) Unloading nouveau
[    51.991] (II) Failed to load module "nouveau" (already loaded, 7838747)
[    51.991] (II) LoadModule: "nv"
[    51.991] (WW) Warning, couldn't open module nv
[    51.991] (II) UnloadModule: "nv"
[    51.991] (II) Unloading nv
[    51.991] (EE) Failed to load module "nv" (module does not exist, 0)
[    51.991] (II) LoadModule: "vesa"
[    51.992] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    51.992] (II) Module vesa: vendor="X.Org Foundation"
[    51.992]    compiled for 1.11.3, module version = 2.3.0
[    51.992]    Module class: X.Org Video Driver
[    51.992]    ABI class: X.Org Video Driver, version 11.0
[    51.992] (II) UnloadModule: "vesa"
[    51.992] (II) Unloading vesa
[    51.992] (II) Failed to load module "vesa" (already loaded, 0)
[    51.992] (II) LoadModule: "fbdev"
[    51.992] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    51.992] (II) Module fbdev: vendor="X.Org Foundation"
[    51.992]    compiled for 1.11.3, module version = 0.4.2
[    51.992]    ABI class: X.Org Video Driver, version 11.0
[    51.992] (II) UnloadModule: "fbdev"
[    51.992] (II) Unloading fbdev
[    51.992] (II) Failed to load module "fbdev" (already loaded, 0)
[    52.100] (II) NVIDIA dlloader X Driver  331.20  Wed Oct 30 17:32:26 PDT 2013
[    52.100] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    52.123] (II) NOUVEAU driver Date:   Wed Nov 30 18:56:54 2011 +0100
[    52.123] (II) NOUVEAU driver for NVIDIA chipset families :
[    52.123]    RIVA TNT        (NV04)
[    52.123]    RIVA TNT2       (NV05)
[    52.123]    GeForce 256     (NV10)
[    52.123]    GeForce 2       (NV11, NV15)
[    52.123]    GeForce 4MX     (NV17, NV18)
[    52.123]    GeForce 3       (NV20)
[    52.123]    GeForce 4Ti     (NV25, NV28)
[    52.123]    GeForce FX      (NV3x)
[    52.123]    GeForce 6       (NV4x)
[    52.123]    GeForce 7       (G7x)
[    52.123]    GeForce 8       (G8x)
[    52.123]    GeForce GTX 200 (NVA0)
[    52.124]    GeForce GTX 400 (NVC0)
[    52.124] (II) VESA: driver for VESA chipsets: vesa
[    52.124] (II) FBDEV: driver for framebuffer: fbdev
[    52.124] (++) using VT number 7

[    52.132] (II) Loading sub module "fb"
[    52.132] (II) LoadModule: "fb"
[    52.133] (II) Loading /usr/lib/xorg/modules/libfb.so
[    52.133] (II) Module fb: vendor="X.Org Foundation"
[    52.133]    compiled for 1.11.3, module version = 1.0.0
[    52.133]    ABI class: X.Org ANSI C Emulation, version 0.4
[    52.133] (II) Loading sub module "wfb"
[    52.133] (II) LoadModule: "wfb"
[    52.133] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    52.186] (II) Module wfb: vendor="X.Org Foundation"
[    52.186]    compiled for 1.11.3, module version = 1.0.0
[    52.186]    ABI class: X.Org ANSI C Emulation, version 0.4
[    52.186] (II) Loading sub module "ramdac"
[    52.186] (II) LoadModule: "ramdac"
[    52.186] (II) Module "ramdac" already built-in
[    52.383] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[    52.383] (EE) NVIDIA:     system's kernel log for additional error messages.
[    52.383] drmOpenDevice: node name is /dev/dri/card0
[    52.392] [drm] failed to load kernel module "nouveau"
[    52.392] (EE) [drm] failed to open device
[    52.392] drmOpenDevice: node name is /dev/dri/card0
[    52.401] [drm] failed to load kernel module "nouveau"
[    52.401] (EE) [drm] failed to open device
[    52.401] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    52.401] (WW) Falling back to old probe method for fbdev
[    52.401] (II) Loading sub module "fbdevhw"
[    52.401] (II) LoadModule: "fbdevhw"
[    52.401] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    52.401] (II) Module fbdevhw: vendor="X.Org Foundation"
[    52.401]    compiled for 1.11.3, module version = 0.0.2
[    52.402]    ABI class: X.Org Video Driver, version 11.0
[    52.402] (EE) open /dev/fb0: No such file or directory
[    52.402] (II) Loading sub module "vbe"
[    52.402] (II) LoadModule: "vbe"
[    52.402] (II) Loading /usr/lib/xorg/modules/libvbe.so
[    52.402] (II) Module vbe: vendor="X.Org Foundation"
[    52.402]    compiled for 1.11.3, module version = 1.1.0
[    52.402]    ABI class: X.Org Video Driver, version 11.0
[    52.402] (II) Loading sub module "int10"
[    52.402] (II) LoadModule: "int10"
[    52.402] (II) Loading /usr/lib/xorg/modules/libint10.so
[    52.402] (II) Module int10: vendor="X.Org Foundation"
[    52.402]    compiled for 1.11.3, module version = 1.0.0
[    52.402]    ABI class: X.Org Video Driver, version 11.0
[    52.403] (II) VESA(0): initializing int10
[    52.403] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    52.467] (II) VESA(0): VESA BIOS detected
[    52.467] (II) VESA(0): VESA VBE Version 3.0
[    52.467] (II) VESA(0): VESA VBE Total Mem: 14336 kB
[    52.467] (II) VESA(0): VESA VBE OEM: NVIDIA
[    52.467] (II) VESA(0): VESA VBE OEM Software Rev: 96.134
[    52.467] (II) VESA(0): VESA VBE OEM Vendor: NVIDIA Corporation
[    52.467] (II) VESA(0): VESA VBE OEM Product: G86 Board - NV_NB8M 
[    52.467] (II) VESA(0): VESA VBE OEM Product Rev: Chip Rev   
[    52.588] (II) VESA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    52.588] (==) VESA(0): Depth 24, (--) framebuffer bpp 32
[    52.588] (==) VESA(0): RGB weight 888
[    52.588] (==) VESA(0): Default visual is TrueColor
[    52.588] (==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
[    52.588] (II) Loading sub module "ddc"
[    52.588] (II) LoadModule: "ddc"
[    52.588] (II) Module "ddc" already built-in
[    52.655] (II) VESA(0): VESA VBE DDC supported
[    52.655] (II) VESA(0): VESA VBE DDC Level none
[    52.655] (II) VESA(0): VESA VBE DDC transfer in appr. 0 sec.
[    52.925] (II) VESA(0): VESA VBE DDC read failed
[    53.009] (II) VESA(0): VESA VBE PanelID read successfully
[    53.009] (II) VESA(0): PanelID returned panel resolution 1680x1050
[    53.009] (II) VESA(0): Searching for matching VESA mode(s):
[    53.010] Mode: 100 (640x400)
[    53.010]    ModeAttributes: 0x3bf
[    53.011]    WinAAttributes: 0x7
[    53.011]    WinBAttributes: 0x0
[    53.011]    WinGranularity: 64
[..]
[    53.078]    BnkNumberOfImagePages: 1
[    53.078]    LinNumberOfImagePages: 1
[    53.078]    LinRedMaskSize: 8
[    53.078]    LinRedFieldPosition: 16
[    53.078]    LinGreenMaskSize: 8
[    53.078]    LinGreenFieldPosition: 8
[    53.078]    LinBlueMaskSize: 8
[    53.078]    LinBlueFieldPosition: 0
[    53.078]    LinRsvdMaskSize: 8
[    53.078]    LinRsvdFieldPosition: 24
[    53.078]    MaxPixelClock: 229500000
[    53.078] 
[    53.078] (II) VESA(0): Total Memory: 224 64KB banks (14336kB)
[    53.078] (II) VESA(0): <default monitor>: Using hsync range of 29.37-64.67 kHz
[    53.078] (II) VESA(0): <default monitor>: Using vrefresh range of 56.00-59.88 Hz
[    53.078] (WW) VESA(0): Unable to estimate virtual size
[    53.078] (II) VESA(0): Not using built-in mode "1680x1050" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "1280x1024" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "1280x800" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "320x400" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "320x240" (no mode of this name)
[    53.078] (II) VESA(0): Not using built-in mode "320x200" (no mode of this name)
[    53.078] (WW) VESA(0): No valid modes left. Trying less strict filter...
[    53.078] (II) VESA(0): <default monitor>: Using hsync range of 29.37-64.67 kHz
[    53.078] (II) VESA(0): <default monitor>: Using vrefresh range of 56.00-59.88 Hz
[    53.078] (WW) VESA(0): Unable to estimate virtual size
[    53.078] (II) VESA(0): Not using built-in mode "640x400" (hsync out of range)
[    53.078] (II) VESA(0): Not using built-in mode "320x400" (hsync out of range)
[    53.078] (II) VESA(0): Not using built-in mode "320x240" (illegal horizontal timings)
[    53.078] (II) VESA(0): Not using built-in mode "320x200" (illegal horizontal timings)
[    53.078] (--) VESA(0): Virtual size is 1680x1050 (pitch 1680)
[    53.078] (**) VESA(0): *Built-in mode "1680x1050"
[    53.078] (**) VESA(0): *Built-in mode "1280x1024"
[    53.079] (**) VESA(0): *Built-in mode "1280x800"
[    53.079] (**) VESA(0): *Built-in mode "1024x768"
[    53.079] (**) VESA(0): *Built-in mode "800x600"
[    53.079] (**) VESA(0): *Built-in mode "640x480"
[    53.079] (==) VESA(0): DPI set to (96, 96)
[    53.079] (II) VESA(0): Attempting to use 60Hz refresh for mode "1680x1050" (169)
[    53.080] (II) VESA(0): Attempting to use 60Hz refresh for mode "1280x1024" (11b)
[    53.080] (II) VESA(0): Attempting to use 60Hz refresh for mode "1024x768" (118)
[    53.081] (II) VESA(0): Attempting to use 60Hz refresh for mode "800x600" (115)
[    53.082] (II) VESA(0): Attempting to use 60Hz refresh for mode "640x480" (112)
[    53.083] (**) VESA(0): Using "Shadow Framebuffer"
[    53.083] (II) Loading sub module "shadow"
[    53.083] (II) LoadModule: "shadow"
[    53.084] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    53.084] (II) Module shadow: vendor="X.Org Foundation"
[    53.084]    compiled for 1.11.3, module version = 1.1.0
[    53.084]    ABI class: X.Org ANSI C Emulation, version 0.4
[    53.084] (II) Loading sub module "fb"
[    53.084] (II) LoadModule: "fb"
[    53.084] (II) Loading /usr/lib/xorg/modules/libfb.so
[    53.084] (II) Module fb: vendor="X.Org Foundation"
[    53.084]    compiled for 1.11.3, module version = 1.0.0
[    53.084]    ABI class: X.Org ANSI C Emulation, version 0.4
[    53.084] (II) UnloadModule: "fbdev"
[    53.084] (II) Unloading fbdev
[    53.084] (II) UnloadModule: "fbdevhw"
[    53.084] (II) Unloading fbdevhw
[    53.084] (==) Depth 24 pixmap format is 32 bpp
[    53.084] (II) Loading sub module "int10"
[    53.085] (II) LoadModule: "int10"
[    53.085] (II) Loading /usr/lib/xorg/modules/libint10.so
[    53.085] (II) Module int10: vendor="X.Org Foundation"
[    53.085]    compiled for 1.11.3, module version = 1.0.0
[    53.085]    ABI class: X.Org Video Driver, version 11.0
[    53.085] (II) VESA(0): initializing int10
[    53.085] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    53.147] (II) VESA(0): VESA BIOS detected
[    53.147] (II) VESA(0): VESA VBE Version 3.0
[    53.147] (II) VESA(0): VESA VBE Total Mem: 14336 kB
[    53.147] (II) VESA(0): VESA VBE OEM: NVIDIA
[    53.147] (II) VESA(0): VESA VBE OEM Software Rev: 96.134
[    53.147] (II) VESA(0): VESA VBE OEM Vendor: NVIDIA Corporation
[    53.147] (II) VESA(0): VESA VBE OEM Product: G86 Board - NV_NB8M 
[    53.147] (II) VESA(0): VESA VBE OEM Product Rev: Chip Rev   
[    53.150] (II) VESA(0): virtual address = 0xb67be000,
    physical address = 0xd1000000, size = 14680064
[    53.172] (II) VESA(0): Setting up VESA Mode 0x169 (1680x1050)
[    53.382] (==) VESA(0): Default visual is TrueColor
[    53.383] (==) VESA(0): Backing store disabled
[    53.383] (==) VESA(0): DPMS enabled
[    53.383] (WW) VESA(0): Option "NoLogo" is not used
[    53.383] (==) RandR enabled
[    53.383] (II) Initializing built-in extension Generic Event Extension
[    53.383] (II) Initializing built-in extension SHAPE
[    53.383] (II) Initializing built-in extension MIT-SHM
[    53.383] (II) Initializing built-in extension XInputExtension
[    53.383] (II) Initializing built-in extension XTEST
[    53.383] (II) Initializing built-in extension BIG-REQUESTS
[    53.383] (II) Initializing built-in extension SYNC
[    53.383] (II) Initializing built-in extension XKEYBOARD
[    53.383] (II) Initializing built-in extension XC-MISC
[    53.383] (II) Initializing built-in extension SECURITY
[    53.383] (II) Initializing built-in extension XINERAMA
[    53.383] (II) Initializing built-in extension XFIXES
[    53.383] (II) Initializing built-in extension RENDER
[    53.383] (II) Initializing built-in extension RANDR
[    53.383] (II) Initializing built-in extension COMPOSITE
[    53.383] (II) Initializing built-in extension DAMAGE
[    53.407] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
[    53.445] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm
[    53.449] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[    53.449] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    53.449] (II) LoadModule: "evdev"
[    53.450] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    53.450] (II) Module evdev: vendor="X.Org Foundation"
[    53.450]    compiled for 1.11.3, module version = 2.7.0
[    53.450]    Module class: X.Org XInput Driver
[    53.450]    ABI class: X.Org XInput driver, version 16.0
[    53.450] (II) Using input driver 'evdev' for 'Power Button'
[    53.450] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    53.450] (**) Power Button: always reports core events
[    53.450] (**) evdev: Power Button: Device: "/dev/input/event2"
[    53.450] (--) evdev: Power Button: Vendor 0 Product 0x1
[    53.450] (--) evdev: Power Button: Found keys
[    53.450] (II) evdev: Power Button: Configuring as keyboard
[    53.450] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[    53.450] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    53.450] (**) Option "xkb_rules" "evdev"
[    53.450] (**) Option "xkb_model" "pc105"
[    53.450] (**) Option "xkb_layout" "us"
[    53.451] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[    53.451] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    53.451] (II) Using input driver 'evdev' for 'Video Bus'
[    53.451] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    53.451] (**) Video Bus: always reports core events
[    53.451] (**) evdev: Video Bus: Device: "/dev/input/event4"
[    53.451] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    53.451] (--) evdev: Video Bus: Found keys
[    53.451] (II) evdev: Video Bus: Configuring as keyboard
[    53.451] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:04/LNXVIDEO:01/input/input4/event4"
[    53.451] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    53.451] (**) Option "xkb_rules" "evdev"
[    53.451] (**) Option "xkb_model" "pc105"
[    53.451] (**) Option "xkb_layout" "us"
[    53.452] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[    53.452] (II) No input driver specified, ignoring this device.
[    53.452] (II) This device may have been added with another device file.
[    53.452] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    53.452] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    53.452] (II) Using input driver 'evdev' for 'Sleep Button'
[    53.452] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    53.452] (**) Sleep Button: always reports core events
[    53.452] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[    53.452] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    53.452] (--) evdev: Sleep Button: Found keys
[    53.452] (II) evdev: Sleep Button: Configuring as keyboard
[    53.453] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[    53.453] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    53.453] (**) Option "xkb_rules" "evdev"
[    53.453] (**) Option "xkb_model" "pc105"
[    53.453] (**) Option "xkb_layout" "us"
[..]
[    53.453] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[..]
[    53.453] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event3"
[    53.453] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    53.454] (**) Option "xkb_rules" "evdev"
[    53.454] (**) Option "xkb_model" "pc105"
[    53.454] (**) Option "xkb_layout" "us"
[    53.454] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[    53.454] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    53.454] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    53.454] (II) LoadModule: "synaptics"
[    53.455] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    53.455] (II) Module synaptics: vendor="X.Org Foundation"
[    53.455]    compiled for 1.11.3, module version = 1.6.2
[    53.455]    Module class: X.Org XInput Driver
[    53.455]    ABI class: X.Org XInput driver, version 16.0
[    53.455] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    53.455] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    53.455] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    53.455] (**) Option "Device" "/dev/input/event5"
[..]
[    53.469] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/serio2/input/input7/event7"
[    53.469] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 11)
    [..]
[    53.470] (II) No input driver specified, ignoring this device.
[    53.470] (II) This device may have been added with another device file.
[    53.472] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event6)
[    53.472] (**) ThinkPad Extra Buttons: Applying InputClass "evdev keyboard catchall"
[    53.472] (II) Using input driver 'evdev' for 'ThinkPad Extra Buttons'
[    53.472] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    53.472] (**) ThinkPad Extra Buttons: always reports core events
[    53.472] (**) evdev: ThinkPad Extra Buttons: Device: "/dev/input/event6"
[    53.472] (--) evdev: ThinkPad Extra Buttons: Vendor 0x17aa Product 0x5054
[    53.472] (--) evdev: ThinkPad Extra Buttons: Found keys
[    53.472] (II) evdev: ThinkPad Extra Buttons: Configuring as keyboard
[    53.472] (**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input6/event6"
[    53.472] (II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 12)
[    53.472] (**) Option "xkb_rules" "evdev"
[    53.472] (**) Option "xkb_model" "pc105"
[    53.472] (**) Option "xkb_layout" "us"

Background: This question is on the back of Nvidia X Server flickers, hangs and segfaults on start-up. I am able to start X only if I install the proprietary Nvidia graphics for my graphics card (say, nvidia-304) in one kernel (3.2.0-23-generic), then boot in a different kernel (3.2.0-57-generic). It clearly uses some fallback driver, but I can't understand if it's nouveau or something else.


EDIT1: As suggested:

liv@malou-laptop:~$ lspci -v
[..]
01:00.0 VGA compatible controller: NVIDIA Corporation G86M [Quadro NVS 140M] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Lenovo ThinkPad T61
[..]
    Kernel modules: nouveau, nvidiafb
[..]

But strangely, these modules don't seem to be in use:

root@malou-laptop:/home/liv# lsmod | grep -i nouveau
root@malou-laptop:/home/liv# lsmod | grep -i nvidia

Although they're clearly available:

liv@malou-laptop:~$ modprobe -l | grep nouveau
kernel/drivers/gpu/drm/nouveau/nouveau.ko
liv@malou-laptop:~$ modprobe -l | grep nvidia
kernel/drivers/video/nvidia/nvidiafb.ko
share|improve this question
add comment

1 Answer

From a console, if you run:

lspci -v

and look at the VGA section, the "Kernel driver in use" will tell you if it's using the nvidia driver. If so, then running:

dpkg -l | grep -i nvidia

will show the versions of the nvidia modules that are loaded.

For more info, see this answer.

share|improve this answer
    
lspci -v outputs Kernel modules: nouveau, nvidiafb. But strangely, these modules don't seem to be in use when checking with lsmod (see EDIT1). –  landroni Jan 10 at 10:17
    
I think that means nouveau is actually the driver in use, so the nvidia module may not be loaded (not sure what the nouveau module is called to see in lsmod). So, if you install the nvidia drivers (sudo apt-get install nvidia-current) and run sudo nvidia-xconfig, then reboot, the system crashes? –  Ash Jan 10 at 12:00
    
From what I can see, nouveau is the kernel module name for the Nouveau drivers (see modified EDIT1), and it is missing from lsmod output here. If I install the latest officially-recommended Nvidia drivers (nvidia-331) for my card, then the Nvidia X Server flickers, hangs and segfaults on start-up (see that question for details). –  landroni Jan 10 at 12:26
    
But what about the drivers from the ubuntu repo for your current installation -- I thought "nvidia-current" would install something appropriate for your distro, rather than just the latest ones? (Could be wrong, was just an assumption). –  Ash Jan 10 at 12:49
    
I tried all Nvidia drivers that 12.04 proposes to the user in Additional Drivers: nvidia-173, nvidia-304 and nvidia-319, in addition to the proposed nvidia-331; all with the same effect of X crashes. According to Nvidia's website, both nvidia-304 and nvidia-331 should support my graphics card, but obviously something doesn't fly. –  landroni Jan 10 at 15:47
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.