Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get hostapd working on a RT3290 (pci-based) network adapter, and a Ubuntu 12.04.3 LTS release. I use the approach taken in How to setup a wi-fi hotspot (access point mode)?

I verified with the "iw list" command that it has AP mode for acting as a access point.

When starting the hostapd daemon, I get the following error:

# sudo hostapd -d /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
nl80211: Register Action command failed: ret=-19 (No such device)
nl80211: Register Action match - hexdump(len=1): 06
nl80211: Failed to register Action frame processing - ignore for now
nl80211: Add own interface ifindex 0
Could not read interface wlan0  flags: No such device
nl80211 driver initialization failed.
ELOOP: remaining socket: sock=4 eloop_data=0x8a5b900 user_data=0x8a5bea0 handler=0x807c5e0
ELOOP: remaining socket: sock=6 eloop_data=0x8a5dd30 user_data=(nil) handler=0x8086770

What can be wrong with this set-up?

share|improve this question

2 Answers 2

The answer is here only

  Could not read interface wlan0  flags: No such device
  nl80211 driver initialization failed.
  1. you may have disabled your wlan0 , so please enable it , if it is so.

  2. The device drivers are not installed properly , reinstall the drivers.

  3. If your wireless device has connected with some other name like wlan1 or wlan2 , please edit that file and replace it with the corresponding device name.

share|improve this answer
    
Thanks for your suggestion. The device drivers work and the device is enabled, because I can connect with it to an other access point. I also disabled the networkmanager to see if that was in conflict with hostapd, but that did not work. The device is made available as wlan0 as shown by 'iw list' or ifconfig. –  Roalt Jan 10 at 21:08
    
I was indeed related to the device not being recognized, see my accepted answer below. But in other cases your line of trouble shooting may help as well. –  Roalt Jan 16 at 8:02
    
@Roalt glad that you have accepted your issue. –  AgentCool Jan 16 at 11:39
up vote 0 down vote accepted

Removing a space character after the "interface=wlan0 " line solved the issue.

I had copied the hostapd.conf from a website: hostapd is due to a bad implementation very sensitive to whitespaces.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.