Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried it a 100 times I'm really new to Ubuntu and ended with a bunch of error that I don't even understand can any one please help me??

Here is what I did:

  1. I installed PHP
  2. I installed libcurl then php5-dev
  3. I tried installing PECL extension and it says PHPIZE not found.
share|improve this question
    
Welcome to Ask Ubuntu. Can please give us the full command you issued and the full error message. Edit your question text to add the information please. –  MadMike Jan 10 at 9:46

2 Answers 2

up vote 6 down vote accepted

First, you will need to install PEAR via apt-get to get the necessary package and distribution system that both PEAR and PECL use. From a shell prompt enter:

sudo apt-get install php-pear

You will be prompted to confirm the install. Just press “y” and enter. If all goes well you should see it download and install the php-pear package.

Now you will need to install the php5-dev package to get the necessary PHP5 source files to compile additional modules. Enter the following from a shell prompt:

sudo apt-get install php5-dev

If you do not install the php5-dev package and try to install a PECL extension using “pear install”, you will get the following error:

sh: phpize: not found
ERROR: `phpize’ failed

The PECL_HTTP extension requires an additional dependency package to be installed. You can probably skip this for other extensions:

sudo apt-get install libcurl3-openssl-dev

Now we are finally ready to actually install the extension. From a shell prompt enter following but substitute “pecl_http” with the PECL extension name you are installing:

sudo pecl install pecl_http

The installer may ask you about some specific options for the extension you are installing. You can probably just hit enter one or more times to accept all the defaults unless you want to set specific options for your implementation. If all goes well, the module should download, build, and install.

Once the install is complete, it will probably ask you to add a “extension=” line to your php.ini file. Open up the php.ini file in your favorite text editor and add the line under the section labeled “Dynamic Extensions”. On Ubuntu the php.ini file seems to be located in the /etc/php5/apache2 folder:

sudo nano /etc/php5/apache2/php.ini

In this example, the pecl_http extension install asked me to add “extension=http.so”. Now that the php.ini file has been updated, Apache will need to be restarted so the new extension will be loaded:

sudo /etc/init.d/apache2 restart 

source

share|improve this answer
    
these were the same steps i followed exactly(from the same source) still no joy :/ i moved to Ubuntu just for some extensions that are not available on windows but this is so confusing because i'm new at this. –  maniteja Jan 10 at 10:17
    
PLEASE NOTE: You might need to install make before doing this. Simply do sudo apt-get install make –  Tomanow Mar 29 at 9:31

In addition to @Ask's answer I also needed to do:

sudo apt-get install libpcre3-dev

before running pecl install pecl_http because I was getting this error about pcre.h:

fatal error: pcre.h: No such file or directory compilation terminated.

Also, instead of editing the php.ini file I created a new file called pecl-http.ini in the conf.d subdirectory of where the php.ini file was, ( on ubuntu /etc/php5/apache2/conf.d )

And I needed to add in three lines:

extension=raphf.so
extension=propro.so
extension=http.so

Finally, since this installed version 2.0.6 I couldn't use the http_get_request_headers function but needed to instead use the namespaced version, \http\Env::getRequestHeader() see more details here

ps: don't forget to restart apache when you're done ( service apache2 restart )

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.