Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Something about the color scheme changed in 11.04, and now it's very difficult for me to tell which tab is the selected one.

enter image description here

On my screen, the colors look more similar the further down I slouch in my chair (i.e. angle of view).

If I change the color scheme the problem is solved, but that solution is too extreme for me. Is there a way to just change the color of the selected tab in terminal, or otherwise make it more prominent?

UPDATE: In 12.10 the accepted solution doesn't work. Can anyone fix it?

share|improve this question
This has been reported as a bug: – Jan Nekvasil Jul 22 '11 at 9:22
I confirm, In 12.10 the accepted solution doesn't work. Bug opened here: – Alessio Dec 14 '12 at 9:44
@Alessio - The new accepted answer works in 12.10 through 13.10. – David Harkness Jan 19 '14 at 19:58
Neither of these solutions is working for me in 12.04. Any ideas? – Lambart Jan 22 '14 at 21:17
up vote 78 down vote accepted

For 12.10–15.04 you can create a CSS theme for GTK 3.0 as explained in this comment by Kees (kees-vanveen) on the bug report posted above by Alessio.

  1. Create the file ~/.config/gtk-3.0/gtk.css

  2. Paste this as the contents using your desired color:

    TerminalWindow .notebook tab:active {
        background-color: #def;
  3. Close all Terminal windows and relaunch the application to see the change.

share|improve this answer
This works and is very easy to do, thanks! – Lachlan Mar 14 '13 at 6:14
Works great -- thanks! As a reminder to anyone trying this solution, you'll need to log out and log back in before changes take effect. – Sam King Jun 6 '13 at 5:56
Just closing all terminal windows and reopening a new session worked for me. – sunew Sep 24 '13 at 11:22
Confirming this works through 14.10. As long as gnome-terminal uses gtk-3, unless they change the spec this should always be a solution. – balloons Jul 24 '14 at 19:00
You can test the change without closing all terminal windows by starting a new terminal with gnome-terminal --disable-factory – Samuli Kärkkäinen Sep 29 '14 at 9:49

I'm not that much of a theme hacker, but here's a quick fix:

Create or edit the file ~/.gtkrc-2.0 to include the following:

style "gnome_terminal_notebook"
  fg[NORMAL] = "#00ff00"

widget "*TerminalWindow.*.GtkNotebook*" style "gnome_terminal_notebook"

This will turn the text color of the active tab green. Not very beautiful, but should give you a start.

You could also lighten up the highlighted tab by replacing the fg line with:

bg[NORMAL] = shade (1.25, "#3c3b37")

The downside: this will also make the inner borders brighter.

Note: This will influence every theme you choose in the appearance properties, so don't forget to undo those changes when using another theme.

share|improve this answer
This workaround works perfectly! You can use #4c4b47 for an even brighter background. – Nicolas Raoul May 31 '11 at 14:35
This suggestion does not work on 12.10 Can anyone confirm it does ? – Scott Stensland Feb 28 '13 at 20:21
@ScottStensland - See my answer for a solution that works on 12.10. – David Harkness Mar 14 '13 at 6:52

Using Ubuntu's warm grey in, this is a small variation of David's:

TerminalWindow .notebook tab {
    background-color: #e2e0dd;

TerminalWindow .notebook tab:active {
    background-color: #f2f1f0;

The color of other tabs here is slightly darker.

share|improve this answer
Thanks, this looks better. – Håkon Hægland Dec 29 '14 at 8:49

You can hack the theme and change colors that way. I did that years ago when a theme I otherwise liked didn't have enough contrast.

Themes installed system-wide live in /usr/share/themes, while your own themes live in ~/.themes. If the theme you're modifying is a system-wide theme, I suggest copying it to ~/.themes and renaming it before making changes. Otherwise, your changes will get overwritten the next time the package responsible for those files gets upgraded.

share|improve this answer

For Ubuntu 16.04, create a file named ~/.config/gtk-3.0/gtk.css, and place the following into it:

TerminalWindow .notebook tab:active {
    background-color: #b0c0f0;


share|improve this answer
This is the same as the accepted answer. – itsadok May 7 at 7:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.