Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've searched through here and have tried to fix this issue but nothing seems to work. I recently installed Ubuntu on my HP PC that came with Windows 8 pre-installed via UEFI. I'm new to Ubuntu and Linux all together but I would really like to learn. So during the installation I chose to "Install Alongside Windows." After completing the installation the option to choose Windows 8 would not work. I had to have use System Setup and go into the boot options and Select Windows Boot Loader. So I searched and saw that I should run boot-repair and so I did. Well after that it added numerous other options in Grub. I can choose Windows Boot UEFI and it will load windows. Now, though when I select Ubuntu it won't boot. It just stays on a blank purple screen. I can only boot into Ubuntu if I have the LiveUSB plugged in. What should I do? I just want to be able to choose between Windows and Ubuntu and they both work. Here's this if it helps..

http://paste.ubuntu.com/6723512

share|improve this question
    
YOur nvram ubuntu points to shim, and the grub.cfg file is using a signed kernel, so is secure boot enabled? Do you get to the black grub screen when booting? –  ubfan1 Jan 10 at 4:37
    
I do not get the black grub screen when booting. It goes to the OS selection and then when I choose Ubuntu just a purple screen. I think secure boot is enabled but not 100% sure. I'll have look it up. –  user233993 Jan 10 at 22:59
    
Can you use Ctrl-Alt-F2 to go to a terminal login screen? That would indicate a video problem on the X server screen (Alt F7 to go back). Still uncertain of your login, what color is the screen (grub) on which you select Windows or Ubuntu? –  ubfan1 Jan 11 at 0:31
    
Okay, so SecureBoot was disable. When I re-enabled it I was able to boot into Ubuntu with no problem. Now with Windows 8 I can boot into it choosing the option that says Windows Boot UEFI with SecureBoot both enabled and disabled. i41.tinypic.com/16gn62x.jpg If I choose the option that says Windows 8 (loader) (on /dev/sda4) with secureboot on and off it does not work. Here a pictures of each screen I get. i41.tinypic.com/2zpjrpu.jpg and i43.tinypic.com/302ruvl.jpg –  user233993 Jan 11 at 0:32
add comment

1 Answer

up vote 0 down vote accepted

Leave secure boot on, and avoid the non-UEFI Windows boot grub entries. Those have the wrong chainloader +1 command instead of an EFI Path. You could try to clean them up by editing the files in /etc/grub.d, but that's not really necessary. Append a good UEFI Windows entry from the grub.cfg file into /etc/grub.d/40_custom, and edit the 30_os-prober to remove the Windows entry (or just remove the permission bit from the 30_os-prober to make all the entries created by it not appear). Then run

sudo update-grub

to update the grub.cfg file and the grub menu. Of course, you could just edit the /boot/grub/grub.cfg file directly, but the changes will get overwritten at the next kernel update.

share|improve this answer
    
Okay, I mean as long as I can get into both. Is it possible to remove all the additional options in Grub so that it's just the Windows and Ubuntu options. There are other family members who use this computer and I don't want them freaking out every time they turn on the computer. –  user233993 Jan 11 at 0:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.