Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I compile compat drivers for atheros ar9485 in Ubuntu 13.10 with the make command, it gives me these errors:

dilip@ubuntu:~/compat-drivers-3.7-rc1-3$ make
make -C /lib/modules/3.11.0-15-generic/build M=/home/dilip/compat-drivers-3.7-rc1-3 modules
make[1]: Entering directory `/usr/src/linux-headers-3.11.0-15-generic'
  CC [M]  /home/dilip/compat-drivers-3.7-rc1-3/compat/main.o
  LD [M]  /home/dilip/compat-drivers-3.7-rc1-3/compat/compat.o
  CC [M]  /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.o
In file included from /home/dilip/compat-drivers-3.7-rc1-3/include/linux/bcma/bcma.h:8:0,
                 from /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/bcma_private.h:8,
                 from /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:8:
/home/dilip/compat-drivers-3.7-rc1-3/include/linux/bcma/bcma_driver_pci.h:217:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_core_pci_init’
 extern void __devinit bcma_core_pci_init(struct bcma_drv_pci *pc);
                       ^
In file included from /home/dilip/compat-drivers-3.7-rc1-3/include/linux/bcma/bcma.h:10:0,
                 from /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/bcma_private.h:8,
                 from /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:8:
/home/dilip/compat-drivers-3.7-rc1-3/include/linux/bcma/bcma_driver_gmac_cmn.h:95:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_core_gmac_cmn_init’
 extern void __devinit bcma_core_gmac_cmn_init(struct bcma_drv_gmac_cmn *gc);
                       ^
In file included from /home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:8:0:
/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/bcma_private.h:25:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_bus_register’
 int __devinit bcma_bus_register(struct bcma_bus *bus);
               ^
/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:169:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘bcma_bus_register’
 int __devinit bcma_bus_register(struct bcma_bus *bus)
               ^
/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:18:21: warning: ‘bcma_bus_next_num’ defined but not used [-Wunused-variable]
 static unsigned int bcma_bus_next_num = 0;
                     ^
/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.c:94:12: warning: ‘bcma_register_cores’ defined but not used [-Wunused-function]
 static int bcma_register_cores(struct bcma_bus *bus)
            ^
make[3]: *** [/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma/main.o] Error 1
make[2]: *** [/home/dilip/compat-drivers-3.7-rc1-3/drivers/bcma] Error 2
make[1]: *** [_module_/home/dilip/compat-drivers-3.7-rc1-3] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.11.0-15-generic'
make: *** [modules] Error 2

How can I fix this?

share|improve this question
    
Do you have a link to the site where did you get the file? –  Lucio Jan 10 at 3:07
    
Sorry, I havn't the link now. But it is not from the official site. –  dilip Jan 10 at 3:15
    
Whenever you are going to compile software, it has a guide (usually it is on the package as README). In order to help you we need what are you compiling and how it should be done. –  Lucio Jan 10 at 3:17
    
I don't understand why you want to install a driver from kernel 3.7 on to your 3.11 system. What driver are you trying to compile? –  chili555 Jan 10 at 3:19
    
Okay chili555, I got it! But when I try to compile compat 3.11, it fails with this error: /sbin/modprobe: invalid option -- 'l' can you give me a help to fix it? –  dilip Jan 13 at 7:13
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.