Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought a Zotac ZBOX Blu-ray 3D ID36 which includes a Ralink rt2860 wifi network adapter and I can´t get it to work under Ubuntu 11.04. I've already downloaded, compiled and install the drivers from the manufacturer's webpage and I've spent more than 7 hours searching for a solution. I've also tried installing Windows drivers through ndiswrapper without success, and I have tried every solution that has appeared on my screen.

Could it be related with the fact that I'm using Ubuntu 11.04 instead of an older version with an older kernel? Or is it just that it is impossible to make that network adapter work under Ubuntu?

I would be very grateful if you'd be too kind to enlighten me with your knowledge.

share|improve this question
    
I'm having the same trouble, only my adapter is RT2870. And I'm not sure exactly when this happened, I upgraded laptops and did a fresh Ubuntu install, and I just tried to use my RT2870 and it doesn't work. It shows up with iwconfig [or ifconfig -a] but "the network is down" ... –  Matt Sep 20 '11 at 14:53
add comment

2 Answers 2

If found a couple of interesting pages on the web. Hopefully these are not the same as you found because both seem to end in a succesfully working wifi with a Ralink RT2860.

First a very recent Topic on Ubuntu forums (4 days old) seems to suggest ralink rt2860 should work but with some effort. Especially the responce by user estevez about blacklisting seems to work.

And there is a Bug report with some more pointers about blacklisting modules on a Natty version from 2010.11 so this one is pretty darn old. There is a newer bug about this card with some weird behaviour depending on the power cord being present and taken out that is pending.

I would like to encourage you to please file a bugreport or to confirm with a current bug that you are affected too. If this gets a permanent fix lots of other users will benefit.

share|improve this answer
add comment

Firmware V26 from the ralink website solves the problem on my EeePC 901 with stock Ubuntu 11.04

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.