Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First I must admit that I did something really stupid.

I de-installed unity from my ubuntu 12.04 LTS to install kubuntu-desktop as I wanted to try out a different desktop environment.

The problem is that by de-installing unity it also de-installed my login screen. Apparently ldm and gdm are not included in the kubuntu-desktop package.

Now this means that when I start my ubuntu with grub, I will get a black screen after the splash screen and I can not do anything. I can't open up a terminal, and I can't press ALT + F2 to install either one of them.

The disk is encrypted and I can not access it from my windows boot. To make the situation even more dramatic: I saved the decrypt key on the same disk on a different partition.

Have I completely locked myself out? Can I alter the grub configuration so that I can get a terminal after the splash?

While typing this I just came up with the idea to boot into my other linux OS on that same disk. Maybe I can get something to work from there.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Boot to recovery mode, drop to a root shell, and run:

mount -o remount,rw /
apt-get update
apt-get install -f
apt-get install kdm

That should install and configure KDM. Reboot and post back if you have problems.

The only other potential problem you might have would be if you need propriety drivers , what graphics card do you have ?

share|improve this answer
    
I have messed up my grub a long time ago due to a tripple boot installation on my computer. Getting it back to work was not an easy task for me, so I used some tool to edit the grub menu. This is why I asked if grub menu can be altered. I'm not sure what the name was again and I can't check that right now. This tool erased the recovery mode I had in my grub configuration. This would've indeed been the simplest option if it were possible for me, but I am going to try maythux's solution as it is more relevant to my situation I guess. I will report back in the morning after a good breakfast. –  SimbaClaws Jan 9 at 22:44
    
To "manually" boot to recovery mode, when booting, edit the grub boot options, and add the word "single" at the end of the linux line , see askubuntu.com/questions/326528/… and wiki.ubuntu.com/RecoveryMode –  bodhi.zazen Jan 9 at 22:49
    
Thank you, I will try this immediately. I was searching for that. My gratitude. –  SimbaClaws Jan 9 at 22:50
    
You are welcome and I made a small update to my answer ;) –  bodhi.zazen Jan 9 at 22:51
    
Dear bodhi.zazen thank you so much for helping me out so far. I got into my ubuntu installation again thanks to your support. I ran sudo dpkg-reconfigure kdm to reset the login screen and this made it work for me. As for your second question, yes I do beleave I have a problem with my Radeon HD5780 (5xxx) Graphics card. My windows have spastic tendencies whenever I move them around. Might you perhaps know of any answer to this weird phenomena? With spastic, ofcourse I mean to imply the kind of stuff you get to see when you don't have any drivers installed for a graphics card... –  SimbaClaws Jan 10 at 1:40
show 1 more comment

Boot from a live CD

chroot to your partition and you can easily install whatever u like.


You’ll want to boot from your Ubuntu Live CD, choosing “Try Ubuntu without any change to your computer” from the boot menu.

Once the system boots, open up a new Terminal window from Applications \ Accessories and then type in the following command:

sudo fdisk -l

This command is used to tell what device name the hard drive is using, which in most cases should be /dev/sda1, but could be different on your system. enter image description here

Now you’ll need to create a directory to mount the hard drive on. Since we’re actually booting off the live cd, the directory doesn’t really get created anywhere.

sudo mkdir /media/sda1

The next command will mount the hard drive in the /media/sda1 folder.

sudo mount /dev/sda1 /media/sda1

Now it’s time for the command that actually does the magic: chroot.

sudo chroot /media/sda1

Now you can do whatever you want then exit and unmount the mounted partitions and reboot

share|improve this answer
    
Just boot to recovery mode, much easier, especially considering the encryption. –  bodhi.zazen Jan 9 at 17:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.