Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For 11.04, I did a fresh install of my system. Part of that install was to install rvm, which sticks a rvm.sh in /etc/profile.d/. This doesn't work as /etc/profile (which loads each +r in /etc/profile.d/*.sh) is not being loaded. According to the documentation, the profile is only sourced if bash is run in login. To verify this, I invoked bash --login, after which rvm was available.

This has worked for me in previous versions of Ubuntu without any configuration. That is, a fresh install of 10.10 will correctly source profile/.d.

My question is: is there anything I'm doing wrong, or are there some new assumptions being made in Natty that have broken this? My current workaround is to source /etc/profile in ~/.bashrc (which is awful as profile is meant to load before bashrc's, but does the trick).

share|improve this question

6 Answers 6

up vote 37 down vote accepted

Per default, gnome-terminal does not start bash as a login shell (I assume you mean bash started inside a gnome-terminal). That means bash will not read /etc/profile or ~/.profile. As you have correctly observed, bash will read those files if started as a login shell.

The quick fix to your problem is to configure gnome-terminal to start bash as a login shell so it will read /etc/profile. To do that you have to enable "Run Command as a login shell" in the gnome-terminal "Profile Preferences" reachable from the Edit menu.

I do not recommend doing this because it messes up the distinction between ~/.profile and ~/.bashrc. Ideally ~/.profile should do stuff which is required only once, during login, while ~/.bashrc should do stuff which is required everytime bash is started.

There is a question and answer at superuser talking about the difference between bashrc and profile. Read there for more information.

From your problem description it seems that the rvm script needs to be loaded only once, during login. As far as I know Ubuntu has configured the graphical login to read /etc/profile/ and ~/.profile. That means, after logging out and a logging in once, the rvm script should be active. If it still doesn't work, then perhaps the rvm script needs to be loaded for every bash session. If that is the case then bashrc is the more appropriate place for the script.

share|improve this answer
    
Setting 'run command as a login shell' did indeed load /etc/profile (and thus the .d's). Thanks for the explanation - it seems like this requires follow up with the rvm folk. –  Marc May 5 '11 at 18:24
4  
Ubuntu 11.04 doesn't seem to read /etc/profile and ~/.profile during login. It's strange because it always worked with older versions. I think this is not a solution but a workaround. –  Luca May 9 '11 at 10:06
    
@lesmana Is there a way I could enable "Run Command as a login shell" from CLI instead of GUI? I'm sshed into a remote server and cant forward X locally. –  Waseem May 3 '13 at 8:11

Installing RVM as multiuser requires the user to run this command:

(because Ubuntu does not source /etc/profile.d at the login)

echo '[[ -s "/etc/profile.d/rvm.sh" ]] && . "/etc/profile.d/rvm.sh" # Load RVM function' >> ~/.bashrc
share|improve this answer
3  
Ubuntu does source the files in /etc/profile.d/ during login because the default /etc/profile loops through, and sources, the files in /etc/profile.d/. However, if this rvm.sh contains code for interactive shells, such as functions or aliases, having them sourced by /etc/profile is pointless. Setup for interactive bash sessions must be in .bashrc. –  geirha Mar 13 '12 at 20:28

There is, however, a file /etc/bash.bashrc that is read by gnome-terminal and is the "system-wide .bashrc file for interactive bash(1) shells."

My call to the rvm function, [[ -s "$HOME/.rvm/scripts/rvm" ]] && . "$HOME/.rvm/scripts/rvm" , went in there, and works just fine for the couple of users on that system.

share|improve this answer
    
gnome-terminal does nothing of the sort. gnome-terminal runs bash (or whatever your login shell is set to in the passwd database) in interactive mode, and bash started interactively reads /etc/bash.bashrc. Well, at least on Debian/Ubuntu. Bash normally does not read a system wide bashrc; debian has patched it to do so. –  geirha Mar 13 '12 at 20:24
    
@geirha : dmitri@Eos:~$ uname -a Linux Eos 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:48:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux dmitri@Eos:~$ cat /etc/bash.bashrc # System-wide .bashrc file for interactive bash(1) shells. # To enable the settings / commands in this file for login shells as well, # this file has to be sourced in /etc/profile. # If not running interactively, don't do anything [ -z "$PS1" ] && return ..... –  Dmitri Mar 14 '12 at 15:56
1  
Yes, obviously, gnome-terminal invokes bash to read that file: if your shell is ksh, then gnome-terminal wouldn't read that file, would it? May I suggest looking up the word "pedant" in the dictionary before you continue using provocative phrases like "does nothing of the sort." –  Dmitri Mar 14 '12 at 16:05

if you have ZSH or OH-MY-ZSH, your profile is /etc/zprofile

share|improve this answer

I have actually found for those who do not like to fully restart their boxes unless it is absolutely required the following...

You do not need to restart the whole machine to have changes to /etc/profile take effect. All you need is to have your XWindows Desktop GUI restart so it re-reads configs (as it would if it were to be started as part of a system-wide restart).

For me I use xUbuntu which uses LightDM but you can sub in whatever executable calls your current desktop.

First, you can not use a terminal emulator from inside the desktop GUI itself to do this (at least not with LightDM) you need to either use SSH or a secondary console (if you hold Ctrl + Alt and hit an F Key or number key you should drop away from your graphical desktop login or screen to a plain terminal window). I also suggest you close out any remote desktop stuff like VNC if you are using SSH (obviously SSH can be connected you just do not want an open VNC window to be polling display 0 while it is trying to restart as this may hang the restart while it waits for you to terminate the VNC session).

I do this all the time with SSH and it is a big lifesaver especially when you are not physically by your machine and do not feel like waiting for a full restart and reconnecting :-D

Now the easy part once in a "secondary" terminal or SSH issue: (Yes, this will kill your current session, be sure you do not mind, save any open documents or work)

sudo service lightdm restart

wait a minute as it kills the desktop and then starts it again (this can take a few good seconds as things are stopped and then executed again on start)

That's it, now when you head back to either console 0 or you go to to use VNC to connect again you will be greeted by the login prompt and login as normal and if you open a terminal emulator and go to issue your command you should now have no problems as everything was re-sourced just as if you did a full machine restart.

Just remember, if you issue sudo service lightdm restart [or stop, start, whatever] from within the desktop environment itself using a terminal emulator the command will just hang there and nothing will seem to be happening. This is because you are currently using that console (aka display) 0 and so it can not fully go down and come back up as it is waiting for the desktop to not be in use before it runs the command.

Last Note: I have not tried to issue restart on the environment from within the desktop in a terminal emulator and then switch to another console that may then restart it, but if you are already going to switch the console then why not just run the command from there as it should be anyways?

share|improve this answer

echo ". .profile" >> ~/.bashrc

And then open another window. I think this is the easy approach.

share|improve this answer
    
Since the default .profile sources .bashrc, this would result in a loop for most users. –  muru Nov 16 at 8:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.