Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I am trying to install the package geda-gschem from universe repo, I get the output:

sudo apt-get -f install geda-gschem
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 geda-gschem : Depends: libgeda (>= 43) but it is not installable
               Recommends: extra-xdg-menus but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The repo contains the package libgeda43, but it is not recognized as the required package libgeda. Does anybody know what can I do with that? Thanks.

share|improve this question
    
Please, copy verbatim the error. Not paraphrasing. –  Braiam Jan 9 at 14:07
    
I would like to, however, my command-line speaks Russian: sudo apt-get -f install geda-gschem Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам: Пакеты, имеющие неудовлетворённые зависимости: geda-gschem : Зависит: libgeda (>= 43) но он не может быть установлен –  victor Jan 9 at 14:19
    
Use LANG=C command. –  Braiam Jan 9 at 14:19
    
sudo apt-get -f install geda-gschem ...Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: geda-gschem : Depends: libgeda (>= 43) but it is not installable Recommends: extra-xdg-menus but it is not going to be installed E: Unable to correct problems, you have held broken packages. –  victor Jan 9 at 14:29
    
Please, edit your question, I can't make sense out your comment –  Braiam Jan 9 at 14:31

2 Answers 2

up vote 0 down vote accepted

The package geda-gschem in Ubuntu 13.10 depends on libgeda42, not libgeda43. Try running these commands from the terminal:

sudo apt-get -f install libgeda42  
sudo apt-get install geda-gschem  

The -f flag in the first command will force Ubuntu to also install the libgeda-common1:1.8.1-3 package which is available in the Ubuntu Software Center in Ubuntu 13.10.

share|improve this answer
    
I tried to install libgeda42. Apt-get says it cannot do that, because it depends on libgeda-common (< 1:1.8.1-3.1~), but 1:1.9.0+git20131202c-0ppa0~saucy will be installed. –  victor Jan 9 at 14:14
    
@victor I can see from your comment that you have added a ppa to your Software Sources, and Ubuntu is trying to install the latest version of libgeda-common from the ppa that you added, instead of the default version of libgeda-common that is in the Ubuntu Software Center. I edited my answer following your comment. –  karel Jan 9 at 14:27
1  
thanks it solved the problem! –  victor Jan 9 at 14:54

Use:

sudo apt-get -f install geda-gschem

hope you can now get it installed.

share|improve this answer
    
With this command I got the same answer that the package depends on libgeda (>=43), which cannot be installed. Thanks anyway –  victor Jan 9 at 14:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.