Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My keyboard layout is supposed to be the Swiss-French keyboard (QWERTZ, pretty similar to the English QWERTY). Here is what is really happening:

  • When the login screen appears, the keyboard layout is correct (QWERTZ). I know that because I can enter my password.
  • When I log in, the keyboard layout switches to QWERTY, even though the only configured layout is QWERTZ. The icon in the tray displays Swiss French and there is no other choice in the drop-down menu.
  • When I click the already selected option Swiss French in the drop-down menu, it realizes its mistake and gives me the correct QWERTZ keyboard layout.

Additional information:

  • I'm using 13.10 on an Acer Aspire V3-571G laptop.
  • Only my (cursed?) session has this problem on the computer.

Update: appears to persist in 14.04.

share|improve this question
    
I'm having exactly this problem on vanilla Ubuntu 14.04 LTS with Unity: system set to en.UK (and it is displayed in the indicator), but at login I get en.US keyboard. Would be good to have an answer! See also possibly related: "Unrecognized keyboard layout after login" – Davïd Aug 28 '15 at 7:22
    
I had this problem on 12.04, 14.04 and now on 15.04 (but not in 10.04 and earlier)... but i cannot reproduce it. Sometimes it is there, sometimes not. I workaround this issue by having a second layout and switching forth and back via indicator. Somebody should make a bugreport yesterday. – mondjunge Aug 28 '15 at 9:25

Go to: System settings > Text Entry. Then use the arrows to select default keyboard. Alternatively, use -/+ to add or remove keyboard respectively. See: Text entry

Make sure that your preferred keyboard layout is number one on that list. Alternatively, remove all the keyboard layout you don’t need from that list of keyboards. Then restart you systems for the changes to take effect.

share|improve this answer
    
You're not answering the question. I know how to change keyboard layout, I just don't know why it switches on startup and how to prevent that. – SteeveDroz Jan 2 at 8:05
    
You make use of the arrows. Make sure that the main keyboard is on top of that list of keyboards. I am not talking about changing keyboards, I am talking about setting keyboards priority for when your system logs in. I had a similar issue with colemark and qwerty and this is precisely how I solved it. Make use of the ^ arrows to move your preferred keyboard to the top of the list. – Tshilidzi Mudau Jan 2 at 8:07
    
So the reason why your system switches to that keyboard on startup is because the keyboard layout you don’t want happens to be on top of that list and hence it receives a higher priority. Does that answer your question? Please let me know how it works out? – Tshilidzi Mudau Jan 2 at 8:40
    
No it's not. English is not even in the list. – SteeveDroz Jan 2 at 9:46
    
Press the + to add it if you need it to be on that list. Remove from that list all the layout you don’t need and only remain with the layouts you need. Furthermore, rank them in the list of your preferred priority :). Layout number one on that list needs to be the keyboard layout you want to use as your default. – Tshilidzi Mudau Jan 2 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.