Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04.3 LTS

I converted my data drives with btrfs. I first did apt-get update before installing btrfs-tools.

Unfortunately, that still only installed version 0.19

I can mount the drives, but the options compress=lzo and commit=60 are not recognized. Since these options were not even present in v0.19, that's to be expected. I installed a .deb package, to update my btrfs-tools.

when I run btrfs version, the answer is Btrfs v3.12

So that's up to date now.

Problem is, I still can't boot with commit=60, and compression=lzo in fstab.

Fstab:

/dev/sdf1  /mnt/6   btrfs    rw,noatime,commit=60,compression=lzo     0  2

when I delete those 2 options, everything works great.

Could this be because the drives were converted from ext4 to btrfs, using the older version (0.19)?

If so, can I update the fs somehow?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

Btrfs mount options are parsed by the btrfs kernel module. You should upgrade your kernel, because Btrfs isn't well supported on older kernels. Fortunately 12.04 has backports of critical 13.10 packages: LTSEnablementStack

sudo apt-get install --install-recommends {linux-generic,xserver-xorg,libgl1-mesa-glx}-lts-saucy

This should upgrade the kernel from 3.2 to 3.11.

Btrfs in-place conversion produces a fragmented filesystem and doesn't let you select some important features. If you have the opportunity to rsync your data onto a new btrfs filesystem, use this:

mkfs.btrfs --nodesize 16k --leafsize 16k --features skinny-metadata /dev/YourDevice
share|improve this answer
    
Thanks for taking the time to answer my question. I have a few empty drives left, would it be best to use your method to make fresh btrfs filesystems on them, move my data, and then make fresh filesystems on the original drives? –  Wannes Jan 9 at 12:53
    
@user233562: Please accept the answer if it has worked for you. –  i08in Jan 9 at 12:53
    
@user upgrade first, move things later. –  Gabriel Jan 9 at 12:59
    
package not found... clicking on that link you Gabriel provided, gives me links for 12.10 and 13.04 packages. No link for 13.10 package available. –  Wannes Jan 9 at 13:01
    
My bad, it's planned for this month. You could either wait a few weeks, figure out another way to get a 3.10+ kernel, or switch away from btrfs. –  Gabriel Jan 9 at 13:09
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.