Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop from System 76 (Galago UltraPro) that runs the Iris Pro 5200 graphics . When I am running the system while plugged in the performance is great. I can play most games without a problem and everything is smooth as silk.

When I run the laptop on battery the CPU (Intel Core i7-4750HQ) throttles down to save power and my games will run slow.

The game that I am specifically running is Europa Universalis IV on the native Steam client.

My question; is there any way to do one of the following:

a) Make the CPU\GPU run on a 'performance' setting so it does not attempt to throttle.

b) Make the laptop think that it is plugged in so that it does not attempt to throttle.

I have attempted to use the cpufreq-set utility to set the frequencies to the max but even with those changes the game will still run slow. Im thinking that the GPU may be what is throttling and not the CPU.

Also, this problem is system wide. It is not just effecting the EUIV game, I am just using it as a benchmark to test settings. The laptop can be running slow in the game on battery and as soon as i plug it in it runs flawless.

share|improve this question

1 Answer 1

The best I could come up with was to issue the following command:

sudo cpufreq-set -g performance

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.