Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • I am trying to install Ubuntu 10.04 on my machine which already has Windows Vista and Fedora installed.

  • I use GRUB to get the boot menu. The GRUB screen looks something like this (has a fedora logo at the bottom)

    alt text

  • The problem is that when I insert the CD and try to boot, it takes me directly to the GRUB menu for Fedora/Vista, nothing for Ubuntu.

  • So, I tried Ubuntu's CD boot helper to help me boot from the CD, and I get this error

    alt text

  • The BIOS says that I should press F2 for setup and F12 for boot options. I tried them. Nothing happens except that it goes straight to the GRUB menu.

What should I do?

share|improve this question
    
Try fanatically and repetitively pressing F2 to get to setup, it usually works for me just to press repeatedly! –  Source Lab Sep 11 '10 at 17:32

3 Answers 3

What you want is for your computer not to even get to GRUB. You want it to check for a CD in the drive before it goes to the hard disc (and loads GRUB).

This is done in a computer's 'BIOS'. Just after you turn the machine on, look for a screen, usually with the manufacturer's logo, but more importantly some text that gives you a button (normally something like F8 or F12 to change the boot order. Or alternatively to change the BIOS Settings or Startup settings. Here you want to 'move' the option to boot from CD above the option to boot from hard disc.

In your case, as you already have GRUB and a linux install, if these keyboard settings don't work, you can add an entry to GRUB to boot from CD by following this guide.

The Ubuntu wiki has an article describing some common problems when booting from CD.

share|improve this answer
    
When the machine boots, pressing F2 or F12 doesn't help, it goes straight to the GRUB menu. –  Lazer Sep 11 '10 at 15:02
    
As GRUB seems unavoidable, is there any way I can instruct to boot from CD drive the next time, from within GRUB? –  Lazer Sep 11 '10 at 15:18
    
up vote 2 down vote accepted

It was a stupid problem.

My machine has function keys that need to be pressed in combination of Fn key (opposite to what is there in most laptops). So, I was trying just that (Fn+F2, Fn+F12).

Turns out while booting, you need to press F2 without the Fn key.

share|improve this answer
    
please mark this (your) answer as solution –  aatdark Sep 13 '10 at 16:11

Maybe you own an USB keyboard which gets activates too late. (Your keyboard is ready when the GREEN light above the Num key is shining.

You can try to press F8 or F12 serveral times during boot.

There are 2 other possibilities:

  1. Try to create an bootable USBStick
    https://help.ubuntu.com/community/USB%20Installation%20Media

  2. Follow this guide to enable grub to boot into a CDrom
    http://cutecomputer.wordpress.com/2006/10/10/boot-cdrom-through-grub/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.