Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a PS3 controller strangely doesn't work if it's connected as /dev/bus/usb/006/002. If it gets assigned any other device number (like /dev/bus/usb/006/003) then it starts working (which can be achieved by unplugging and plugging it in again). I couldn't figure out why that is the case so I thought maybe there is a way to simulate that USB unplugging and plugging in again.

Does anybody know how to do this?

Edit after having gotten this question closed as a duplicate:

I tried the solutions on the referenced ticket (How do you reset a USB device from the command line?) but they provide no solution to my problem: They reset the USB device - but the device does not get a different device number assigned afterwards so the controller still doesn't work until it is reconnected.

share|improve this question
    
I believe this question is not a duplicate: The solutions from the ticket you mentioned may reset the USB device but it does not get a different device number assigned afterwards. –  Beni Jan 8 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.