Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have recently installed Ubuntu 12.04 LTS and have installed xscreensaver. As I am the only user on this computer and I am only using the computer for music, movies, and some web browsing I have no need for the extra security of a lock screen. Under user accounts, automatic login is turned on. Under brightness and lock, the lock is turned off and require my password when waking from suspend is unchecked. Under xscreensaver preferences, the lock screen box is unchecked.

Every time the computer goes into suspend I get an xscreensaver lock screen upon waking it. Is there a setting I'm missing or something?

From what I understand removing xscreensaver will fix this, but I would consider that a last resort if I can not resolve this issue as I like to use my photos as a screensaver.

I have just began using linux and really don't know what I'm doing so you're patience and and any help would be much appreciated.

share|improve this question
just to be sure that the problem is really xscreensaver, can you turn off xscreensaver (simply execute killall xscreensaver, no need to uninstall it), then suspend your computer, wake it up again and check if the problem persists? –  Malte Skoruppa Jan 8 '14 at 19:15
The login screen I receive looks nothing like the normal ubuntu login screen, the screen is black and in the middle is a box that say xscreensaver on it. To be certain I followed your instruction and as expected once xscreensaver was shut down everything worked normally, without a login screen. –  Joe Jan 8 '14 at 19:25
Digging for answers to this, I found…. Please have a look, one of those answers may solve your problem. If you think your question may be a duplicate of that thread, please flag it so. –  Malte Skoruppa Jan 8 '14 at 21:39

1 Answer 1

Take a look at this AskUbuntu Question.

Basically, you should also disable screen locking in power manager settings

If you are not using power manager, you can try to comment out line LOCK_SCREEN=TRUE in /etc/default/acpi-support

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.