Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed Ubuntu 12.04 onto a new hard drive, with Windows XP on a separate hard drive. I physically set the Ubuntu drive as primary and it shows as sda. The boot loader is on this drive too. I left the Windows drive completely alone.

On boot, Windows XP Proffessional is listed as one of the options, but when I choose this an error is shown. error: no such device F47836067835C85E error: hd1 cannot get C/H/S values

I am able to boot into Ubuntu.

I have disconnected the Ubuntu HDD and reconnected it to the primary position on the motherboard so that I can re-access Windows!

Please can anyone help? I gave up on Linux 8 years ago, and whilst it seems easier in some ways, there are still huge complications!

Many thanks in advance.

share|improve this question

It doesn't matter what boot loader you're on when installing an OS on two separate hard drives. Each drive will have its own boot loader.

You should make your BIOS to make you choose at startup which hard drive to boot on. A boot loader cannot tell your computer to redirect you to another distinct hard drive for booting.

So you get a "no such device" error because a separate hard drive is out of its scope for any boot loader.

I don't know much about BIOS configurations for all computers, but fiddling around BIOS setup you should work something out. (post a screenshot when you're stuck)

Alternative: Each time your PC is booting, repeatedly press the boot device selection menu key (probably F9, F10, F12 or Esc) and choose your preferred drive to boot on each time.

share|improve this answer
Thank you very much Doruk. I reconnected the Ubuntu drive as a 2nd drive on main board, but wasn't recognised. In Setup I changed that drive to 'on', although in the 'details' part of Setup it was listed as 'unknown' (unlike the other drive that listed make and size). However when I rebooted I was automatically taken to a boot options menu and able to select either Ubuntu or Windows XP. So it seems that the reason I could not boot the Windows HDD was that I had not 'turned it on' in Setup. Dual booting with two hdds with Linux & XP CAN be done without entering bios each time! Thanks again. – Captcooke Jan 15 '14 at 10:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.