Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 13.10 here. I have two external HDDs that are (almost) always plugged in. I want them to automout at startup, so I added two startup entries:

udisksctl mount --block-device /dev/disk/by-uuid/DISK1_UUID_HERE

and same for HDD2.

Now they almost always mount, almost. When they dont, running any udisksctl command will mount them. For example, even running only udisksctl dump mounts the two drives correctly.

Do you have any idea about why sometimes they don't automount properly at startup?

Thanks a lot

share|improve this question
    
This can be hardware issues. This is because sometimes the external hard disk takes too long time to respond. This is completely normal, there's nothing wrong with your hardware or software, it is just the nature of the hardware. –  user220402 Jan 8 at 13:29
    
@user220402 :Oh well that's interesting.. But can't one use a workaround? Like "if the hard disk is alive mount it, otherwise try it again in 3 seconds" very roughly speaking? –  Dave Jan 8 at 16:54

1 Answer 1

Answering old questions...

  • Hold the Super key (usually the same as the Windows key) and hit a.
  • Type startup in the text entry field. Dash 'Startup'
  • Startup Applications should show up - click on it
    (or use the cursor keys to select it and press Enter)
  • Startup Application Preferences should show up - click Add enter image description here
  • Fill in the upper and lower fields with any text you wish.
  • The middle field specifies what to do, type in
/bin/bash -c '/bin/sleep 5 && /usr/bin/udisksctl mount -b /dev/disk/by-label/GreenWD_3TB'

... where /dev/disk/by-label/GreenWD_3TB may be anything(?) that:

find /dev/disk/* -type l -printf "/dev/%l\t%p\n" \
| sed -re 's,\.\./,,g' -ne '/\/dev\/[a-z]+[0-9]\t/ p'

... does display. (The text is formatted so that you may copy it 'as is' into the terminal)
I'd recommend to NOT use anything from the first column though - especially with removable devices as USB-sticks and/or drives.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.