Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a new Lenovo ThinkPad T440p. This laptop comes with a Nvidia GeForce GT 730M/Intel HD 4600 hybrid graphics card. I am now trying to connect the laptop with the Lenovo ThinkPad Ultra Dock to two monitors via DisplayPort - but with no success so far.

If the laptop is connected to the docking station during the booting process, the login screen never appears. All monitors stay black but the integrated monitor is backlit. As soon I disconnect the laptop from the docking station, Xorg continues to load and the login screen appears.

If I connect the laptop to the docking station after logging in, the integrated display still works. But as soon as I try to activate one of the external displays in XFCE4 Display Settings the screen freezes. After disconnecting the laptop from the docking station it works again. Both situations can be reproduced with or without proprietary Nvidia drivers (319 and 331).

Here is the kernel output with additional DRM debug information: http://pastebin.com/FMV9kj67

Here is the output of Xorg: http://pastebin.com/W3U9T8pT

I also tried newer kernel versions (3.12 and 3.13) which didn't help either.

nvidia-settings and nvidia-xconfig do not recognize the external monitors when connected to the docking station. I have heard that in some ThinkPad models the DisplayPorts are wired to the Intel GPU directly. Does somebody have any information about this? Does it even matter?

share|improve this question
    
If I'm not mistaken, the DisplayPort in Linux is quite problematic right now. –  Braiam Jan 8 at 17:06
    
I just found some details about how the displays are connected to the GPUs: download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/gjde44ww.txt NVIDIA GeForce GT 730M, GeForce GT 720M - No display is connected to this display adapter. –  Pascal Beyeler Jan 9 at 12:14

2 Answers 2

up vote 0 down vote accepted

Lenovo has released a firmware-update for the dock, see: http://forums.lenovo.com/t5/T400-T500-and-newer-T-series/T540p-T440p-UltraDock-external-display-issues/td-p/1368847/page/14

For now, the update is Windows-Only, but after the update the dock works with Linux.

What ist NOT solved, is the Bug with the power-adapter shipped with the dock: I still have to use the power-adapter shipped with the Notebook itself.

share|improve this answer
    
Using this firmware, the laptop is able to boot when it is docked. Unfortunately, there is another problem as the Linux Intel graphics card driver does not support MST (Multi Stream Transport) for Display Port. So there is only support for one external monitor. If you connect multiple monitors the screen will be mirrored. –  Pascal Beyeler Feb 13 at 10:44
    
Have you tried setting the nvidia-driver to "NVIDIA (performance Mode)"? With my T420 I couldn't use any external monitor, when intel-only was enabled, so I had to use the nvidia-only option in the dock. –  Eddie Feb 14 at 14:24
    
Yes, the only solution is to use the nvidia-only option. –  Pascal Beyeler Feb 17 at 7:36

I also can reproduce this with actual developer Version of ubuntu 14.10. T440p, Thinkpad Ultradock, connected with DisplayPort and I also tired DVI.

Interesting: With a mini-Displayport cable connected to the laptop directly everything works, so perhaps this is a workaround for you also!

BTW: Displayport with my old T420 (with or without dock) works just fine!

share|improve this answer
    
I guess it will be difficult to connect two monitors to the mini-Displayport. My temporary workaround is to use Windows 7 as host OS and Xubuntu as guest :-/ –  Pascal Beyeler Jan 9 at 12:28
    
Is there a bug in launchpad or anywhere else? –  Roland Jan 10 at 3:00
    
This bug report here sounds similar to my problem: bugs.freedesktop.org/show_bug.cgi?id=71267 They are actively working on it –  Pascal Beyeler Jan 10 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.