Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.04 into a partition on the hard drive on my MacBook Pro 15'' with Retina Display. I used this tutorial to install it. I then ran apt-get update and upgrade. After that I purged the nvidia packages and installed nvidia-current because I had problems with virtual versions of 13.04 and I thought it might help. Now when i boot up my Ubuntu partition it displays some white text before going to a black screen. Holding shift or pressing alt-ctrl-F1 does nothing. Is there any way to get into it to fix it? If not when I reinstall it how should I do it so this doesn't happen again? If you don't know is there a way I can save the state of my os before I run upgrade so I don't have to keep reinstalling it every time I try something? Thank you.

share|improve this question
add comment

1 Answer 1

Dont use nvidia current as you are on a Hybrid system with iGPU + dGPU you need to install the following:

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

The nvidia-prime is what bumblebee used to be and it's called nvidia optimus.

Hope you get your problem fixed.

share|improve this answer
    
I tried to install nvidia-prime but apt-get said that it could not find the package. I looked into it and it seems that it is not available for 13.04. If it helps this is the graphics card that I use: NVIDIA GeForce GT 650M 1024 MB. –  qazmonk1 Feb 2 at 20:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.