Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running ubuntu 10.10 64 bit on my mac mini. After installing nfs-common, and attempting to mount using

mount -t nfs4 -o proto=tcp,port=2049 ./test

I keep getting this error:

mount.nfs4: mounting failed, reason given by server: No such file or directory

When i run

showmount -e
Export list for
/volume1/magneto *

It seems to indicate that the volume is there and that i'm typing the correct thing. I tried removing the trailing slash and no luck.

Does anyone have any idea why this is happening? I'm using this NAS:

share|improve this question
up vote 2 down vote accepted

Unlike NFSv3, NFSv4 hides the prefix of the exported path (the NFS root). The prefix is configured in the exports on the NAS.


mount -t nfs4 -o proto=tcp,port=2049 ./test


mount -t nfs4 -o proto=tcp,port=2049 ./test
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.