Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to fix the the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present error message on boot, so I followed the advices given here What to do about "the disk drive for /dev/mapper/cryptswap1 is not ready yet or not present"?

Now what happens is that when I reboot after having formatted my swap partition to linux-swap, it resets to an "unknown" partition (as displayed in Gparted).

Though it seems to exist and function, I still get that "disk drive not ready" on boot. So what about? Is this all normal?

swapon -s:

Filename                Type        Size    Used    Priority
/dev/mapper/cryptswap1                  partition   8349692 0   -1

free -m:

             total       used       free     shared    buffers     cached
Mem:          7953       1607       6345          0        111        604
-/+ buffers/cache:        892       7060
Swap:         8153          0       8153
share|improve this question
    
Have you tried removing the partition and re-add it? –  Braiam Jan 7 at 23:47
    
I'm not sure of the procedure for that? –  SirNeirda Jan 8 at 0:02
    
Basically, you boot from a system rescue CD/flash drive and run gparted or a similar tool. Find the swap partition (usually labelled "swap" on your system drive (usually /dev/sda). Tell it to delete the partition and let it do it (apply changes). Then add it back in using the same tool. (There are fancier ways to do it without rebooting, but I think this way is simpler.) –  Joe Jan 9 at 5:21
    
I've never used an encrypted partition (and /dev/mapper), so I may be way off here, but it would be interesting to see what's in /etc/fstab (cat /etc/fstab in a console and copy and paste it into a post here.) That's where the basic partitions of a system are defined (and where all partitions used to be defined.) Mine looks like this # swap was on /dev/sda8 during installation UUID=3d9fe1af-25fe-4d28-82c9-5c2b4d895b79 none swap sw 0 0 –  Joe Jan 9 at 5:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.