Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm new to Ubuntu (12.04.3). I'm trying to install handbrake and I've tried about 6 different ways non seem to work, so I'm now asking for help.

Step 1 sudo add-apt-repository ppa:stebbins/handbrake-releases

$ sudo add-apt-repository  ppa:stebbins/handbrake-releases
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 128, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/", line 84, in get_ppa_info_from_lp
pycurl.error: (35, 'gnutls_handshake() failed: A TLS packet with unexpected length was received.')

I get and error what does the error mean and how do I fix it?

In file /etc/apt/sources.list I have this

deb quantal main
deb-src quantal main

If I ignore the error and continue.

Step 2 sudo apt-get update

I get.

W: Failed to fetch  Unable to find expected entry 'deb-src/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead.

Again if I ignore the message

and continue.

Step 3 sudo apt-get install handbrake

I get.

Package handbrake is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

W: Duplicate sources.list entry oneiric/main i386 Packages (/var/lib/apt/lists/ppa.launchpad.net_stebbins_handbrake-releases_ubuntu_dists_oneiric_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
E: Package 'handbrake' has no installation candidate

If I use sudo apt-get install handbrake-gtk

I get this.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 handbrake-gtk : Depends: libgstreamer-plugins-base1.0-0 (>= 1.0.0) but it is not installable
                 Depends: libgstreamer1.0-0 (>= 1.0.0) but it is not installable
                 Depends: gstreamer1.0-libav but it is not installable
                 Depends: gstreamer1.0-plugins-base but it is not installable
                 Depends: gstreamer1.0-plugins-good but it is not installable
                 Depends: gstreamer1.0-plugins-bad but it is not installable
                 Depends: gstreamer1.0-plugins-ugly but it is not installable
                 Depends: gstreamer1.0-pulseaudio but it is not installable
E: Unable to correct problems, you have held broken packages.

*Sigh nothing works :(

share|improve this question

Add the repository
sudo add-apt-repository ppa:stebbins/handbrake-releases
Then update:

sudo apt-get update

Then install:

sudo apt-get install handbrake
share|improve this answer
How do I add the repository? – Another Compiler Error Jan 7 '14 at 23:33
I have this ##ppa:stebbins/handbrake-releases deb quantal main deb-src quantal main at the end of /etc/apt/sources.list file. – Another Compiler Error Jan 8 '14 at 0:07
sudo add-apt-repository ppa:stebbins/handbrake-releases – Brask Jan 8 '14 at 0:10
You don't need to do sudo apt-get upgrade to install a new package. update is enough. – Alvar Jan 8 '14 at 0:14
please explain to me the difference between what I did in my "step 1" and the error it produced and your response. – Another Compiler Error Jan 8 '14 at 0:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.