Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have headless Ubuntu 13.10 on a little ARM device (a BeagleBone) with a wifi adapter connected to it. I'm unable to get an IP from DHCP: 'sudo dhclient wlan0' takes a while to run and when it comes back the wlan0 still doesn't have an IP.

I added this to /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
wireless-essid   MSFTOPEN
wireless-channel 1
wireless-mode    managed

The wifi adapter does show up in ifconfig and iwconfig but it just doesn't get an IP. Here's the output of iwconfig and ifconfig:

$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:9e:95:9b:58:a5
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


$ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"MSFTOPEN"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=20 dBm
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

eth0      no wireless extensions.

usb0      no wireless extensions.

The network I'm trying to connect to does show up when doing iwlist wlan0 scan. Here's the snippet:

  Cell 04 - Address: 00:24:6C:2C:A4:21
            Channel:1
            Frequency:2.412 GHz (Channel 1)
            Quality=35/70  Signal level=-75 dBm
            Encryption key:off
            ESSID:"MSFTOPEN"
            Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                      36 Mb/s; 48 Mb/s; 54 Mb/s
            Mode:Master
            Extra:tsf=000000139a19b001
            Extra: Last beacon: 72ms ago
            IE: Unknown: 00084D5346544F50454E
            IE: Unknown: 01088C129824B048606C
            IE: Unknown: 030101
            IE: Unknown: 2A0100
            IE: Unknown: 2D1ACC111BFFFF000000000000000000000000000000000000000000
            IE: Unknown: 3D1601001B000000FF000000000000000000000000000000
            IE: Unknown: DD1E00904C33CC111BFFFF000000000000000000000000000000000000000000
            IE: Unknown: DD1A00904C3401001B000000FF000000000000000000000000000000
            IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
            IE: Unknown: DD0A00037F04010000000000

Any ideas what I should try here?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.