Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I plan to buy ASUS Xonar U7 USB sound card but don't see drivers for Linux in the ASUS site. I don't see it in the ALSA supported cards page either (http://www.alsa-project.org/main/index.php/Matrix:Vendor-Asus). Does anyone know whether its supported in Linux?

share|improve this question
    
I am also interested in this. Just bought an external driver. :-) –  Ionică Bizău Jan 10 at 12:48
    
On my computer (Ubuntu 14.04 x64) it doesent't work, but on my 2nd computer on win 8.1 it works perfect. On boot, i can hear the "click" from the U7 and the blue headphones LED is turned on, that means it must be initialized...but not really. I've tried the tipps above, with no success. In the VLC media player i can see all the U7 devices in the preferences menu, but none of them is working. No chance to get the U7 up and running here. Maybe Asus has changed something to the chipset or firmware... –  user286781 May 30 at 9:36

5 Answers 5

I tried the Xonar U7 on Mint 16 (based on Ubuntu 13.10) and it works fine (I haven't tried multi-channel though). Absolutely no noise, the sound is perfect with alsa k3.11.0-12-generic, alsamixer v1.0.27.1 and pulseaudio 4.0.

On 29th January the alsa-wiki page provided in the first post was updated, and now the Xonar U7 is supported. With the alsamixer is also possible to change the gain setting.

To fix the broken pipe error : We have to add options snd-usb-audio ignore_ctl_error=1 at the end of alsa-base.conf:

sudo gedit /etc/modprobe.d/alsa-base.conf

add options snd-usb-audio ignore_ctl_error=1, save and close.

alsa force-reload

then

alsamixer

press F6 and select "Xonar U7", now you can change the "Speaker Front" value to increase/decrease the headphone output gain.

share|improve this answer
    
I can't tell you enough how grateful I am for your answer. I'm travelling for another 6 months and have U7 as my only sound source as the jack in my machine has broken, which is why I bought the U7 before leaving the UK. The low sound output was an embarrassment at parties. Kisses. –  tomwrong Apr 4 at 5:13

I have one, it works, but it's not something you should look forward to. Very loud, very noisy. It works out of the box though, but yeah, if you're looking for better quality sound, I would say get something that's not ubuntu or become software developer to make your own drivers.

share|improve this answer

It works perfectly in Ubuntu with ALSA, but only with the minimum gain setting (I can't figure out how to change the default gain setting). BTW, this card has the lowest noise I ever seen: it's practically noiseless!

share|improve this answer

The U7 soundcard is supported, yet I've noticed on my PC that the multimedia keys (configured to use amixer) to raise or lower the volume don't work as they do with my internal xonar DX. I wonder if it's a conflict with this one already installed in my pc which (unlikely) could be resolved by removing or disabling the DX...

share|improve this answer

To make the Xonar U7 analogic multichannel playback fully work on lubuntu, you need to do the following:

1- in file /etc/modprobe.d/alsa-base.conf, change the line options snd-usb-audio index=-2 to options snd-usb-audio index=0 in order to set the U7 as your default sound card

2-in home file /.config/openbox/lubuntu-rc.xml

set the volume keys with amixer lines such as: XF86AudioRaiseVolume: amixer -c 0 sset Speaker 3+ unmute XF86AudioLowerVolume: amixer -c 0 sset Speaker 3- unmute XF86AudioMute: amixer -c 0 sset Speaker toggle using the 'Speaker' control

Hope this will help :-)

share|improve this answer

protected by Community Sep 6 at 15:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.