Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm pretty new to Ubuntu. I installed Ubuntu Netbook Remix 10.10 and it works perfectly. I recently upgraded to 11.04 and now the internet is very slow; when browsing it would take quite a while to simply load a page. I tried switching browsers and it would still happen. I've changed back to UNR so the Internet is usable. Any ideas of what I should try? Thanks.

share|improve this question
Instead of completely removing your original question you should add a comment at the bottom. Your original question should be preserved so other people with similar problem might find the solution easier. – Vilmantas Baranauskas May 11 '11 at 12:55

MAybe it is usefull for you to see this previous post:

Wifi too slow with an Atheros AR928X

(I don't know if it is your case (it's usefull if you can post here your wich drivers do you use... or which type of internet conection u use, ethernet or Wlan?)

for that you should run on terminal this command:


share|improve this answer
Ran the command on terminal and this is what shows, whilst on UNR: lo no wireless extensions. eth0 no wireless extensions. wlan0 IEEE 802.11bgn ESSID:"Beans-Interweb" Mode:Managed Frequency:2.437 GHz Access Point: 00:26:F2:02:E7:2A Bit Rate=54 Mb/s Tx-Power=20 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:off Link Quality=70/70 Signal level=13 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0 – jubberz May 5 '11 at 13:01
Oh please excuse the name of our internet, housemate did it lol.* – jubberz May 5 '11 at 13:04
@jubberz Put all this information in your original question (just edit it) - that way it doesn't get buried in the comments. – Jorge Castro May 6 '11 at 19:13
up vote 1 down vote accepted

I think I finally found the solution to my problem, only just done it and so far my browser is back to normal, if it changes or deteriorates i will let you know though.

I identified my driver to be an RT3090 and then found this post: I followed it and blacklisted the suggested rt drivers and FINALLY i think it has worked! Browser is back to normal speed instead of taking forever to load!

Thanks very much for everyones help, i hope this works for someone else! Maybe now i can enjoy 11.04! :)

share|improve this answer
Hi, I also experienced a huge slowdown in Chrome / FF4. After reading this, I switched from my PCI ethernet card to my second (internal) and surf speed seems to be back to normal. – n3rd May 30 '11 at 16:12

I had the same problem too and I'm new to Ubuntu. On Windows I noticed that the IPv6 settings was on automatic but in Ubuntu the IPv6 settings was on ignored.

I simply changed it to automatic and now the Internet works great on every browser. Hope this helps.

share|improve this answer

There are many factors that can impact your Internet performance. Your ISP's performance can vary. Comcast in Fresno can run slower and slower for a few weeks and then become fast again. I suggest you run or another performance site to establish the actual network performance. In my personal experience with Comcast all of my network slowdowns have been ISP related with one exception when my cable modem started to die. Your ISP should be able to test your modem from the network. This isn't to say that your problem can't be perhaps driver related but you can easily verify network operation to get a complete picture of what's going on.

share|improve this answer
Just ran a speed test as suggested results are here: Not really sure what it means? But as i said, i'm not experiencing any slowness at all when using Ubuntu Netbook Remix, which is what i'm using now. – jubberz May 5 '11 at 12:59

It sounds like Remix was using a different and a better driver for your wifi card. See if you can find out which driver and which version the 2 OS's are loading respectively.

You can try using lshw -C NETWORK and lsusb to find out this information. This should be at least enough to help you track this down. You could paste this here, or start a new more detailed questions that contains this information.

I had this problem upgrading from Maverick to Natty. In the end, I had to blacklist some drivers which forced the system to use a different driver. `

share|improve this answer
Thankyou for this suggestion, i'll try this and post an update! – jubberz May 7 '11 at 15:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.