Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want total absolute control over the brightness of my laptop's screen. I want Natty to fear my wrath should it dare to presume my desire. Natty's light adjusting minions should quake in terror before my sword, apt-get purge!

But alas, this sword cuts an arm where I'd prefer lobotomy. I need a scalpel, some precise tool to cut into Natty's brain and enforce my will. Does such a tool exist? Is there known to the citizens of Ubuntu a method to restore my sovereign power?

Further investigation reveals Natty only auto-dims the screen when running loose on battery power. Chain the beast to an electrical outlet and it is tamed.

I see these two screens in Natty's Power Management, neither appear relevant:

Power Management Preferences - On AC Power Power Management Preferences - General

share|improve this question
7  
+1 for such a well-worded question. –  Nathan Osman May 4 '11 at 23:07
3  
Funniest question I've seen yet. +1. –  boehj May 5 '11 at 4:50
5  
This may just be bad assumption on my part, but did you try leeches? I feel like a person of your caliber should try leeches. +1 for the chuckle. –  Leron May 5 '11 at 5:29
    
I have having the same problem. I have a toshiba Satellite L755D-S5204. It's otherwise a great machine and runs ubuntu very well. But the battery tab options doesn't show up. –  user24103 Aug 29 '11 at 21:56

3 Answers 3

You write much, and well, but say little :-p

What is your problem you wish to solve, exactly? As far as I know, the gnome power manager is the place that controls the brightness depending on things like are you connected to AC or not. There are also knobs in there for how long to wait before dimming the display, or not at all.

Press Super and type in "power", only one app will show up, there's the extent of the brightness control.

share|improve this answer
up vote 4 down vote accepted

@ppetraki's answer, while not fully sufficient, is a boon. If it is Gnome Power Manager that controls such things, then it is Gnome Power Manager that is defective. Revised search terms tell tale of similar woes in Maverick Meerkat. The solution then, as I find now, is hacking Unity with gconftool-2:

gconftool-2 --set --type boolean  "/apps/gnome-power-manager/backlight/enable" false

I'm not fully satisfied with this. Surely I'm not the only one confounded by this behaviour, and surely it would make sense to include such an option in the Power Manager gui. But at least the option exists somewhere, and Natty Narwhal's obnoxious behaviour is restrained.

share|improve this answer
3  
I think you found a bug, the tab that manages your power state when you're on battery isn't showing up. Which means whatever ACPI methods that surround battery life and presence is reporting false/no information. Normally you would just uncheck "reduce backlight brightness" and/or "dim display when idle" under the battery tab and be done with it. Please install fwts from universe, run the full battery (no pun intended) of tests and file a bug with the resulting data. Perhaps we can get enough triage information to compel your laptop vendor to fix the bug. –  ppetraki May 5 '11 at 13:27
    
@ppetraki Will do. –  djeikyb May 9 '11 at 18:37

You can also use a utility such as Caffiene to inhibit such behavior (yes, I know, not ideal):

You can find more info here, or on launchpad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.