Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 13.04

I followed the instructions on the website and everything is set up. I have this service set up on my sister's PC and my mother's Mac. But, when I installed it on Ubuntu, it never works unless I keep the Cipher and HMAC authentication settings as both "default". The Cipher and HMAC, under advanced settings in the VPN "config menu, seem to only work on the "default" setting.

What is the default and why can't I set it to my preferred encryption level - 256 AES CBC/CFB and SHA - 512?

These are the instructions I used: https://www.privateinternetaccess.com/pages/client-support/#linux_ubuntu_openvpn_12_04

Here is a step-by-step guide, in screenshots. The following four links should show you what I'm talking about:
http://postimg.org/image/sdi03wy85/
http://postimg.org/image/fonpk8s3p/
http://postimg.org/image/8zh6486rp/
http://postimg.org/image/oaqz4u43p/

When I go to edit my VPN settings this is what I encounter:

  • VPN Settings I select "configure VPN..."
  • Once inside the "network connections box" I select a VPN connection to edit, in this case PIA - California, and then select "edit".
  • Then a box appears with three tabs...general, vpn, and IPV4 settings...under the VPN tab I select "advanced".
  • Under "OpenVPN advanced options" I find 4 tabs....General, Security, TLS Authentication, and Proxies. I select the security tab and there are two choices: "Cihper" and "Hmac Authentication" both of which are set at "default".

I don't know what default is and when I try to change either to a security setting I know it doesn't work anymore. What is the "default"?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.