Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed ethtool and ran "ethtool -s eth1 wol g" to allow my server to wake up on magic packets, this works but is not quite what i want.

My server only gets accessed from within my home network.

Before i changed my server to Ubuntu I had a windows server, it was set up so when ever I tried to access a mapped network drive it would bring the computer out of sleep mode, then after 40 minutes of been idle it would go back to sleep until accessed again, the server only ever gets accessed manually so it stayed asleep until needed. I did this by selecting "allow this device to wake the computer" on the network card power properties via device manager. I then deselected the box that said wake up with magic packet only.

I know there is different letters instead of "g" on this command "ethtool -s eth1 wol g" but not sure which one to use ?

Does anyone know the commands I need to use to achieve the wake up from Lan on demand? I have searched high and low on the net with no luck :(

Any help would be greatly appricated

EDIT :

These are the letters you can add at the end instead of "g" and apparently what they do.

a - Wake on ARP

b - Wake on broadcast messages (only MAC)

g - Wake on MagicPacket(tm)

m - Wake on multicast messages (multiple ips and MAC)

s - Enable SecureOn(tm) password for MagicPacket(tm)

u - Wake on unicast messages (ip and MAC)

Which one should i use?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.