Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is NOT a request for killing applications.

I can well kill all process, no matter what. That's not the issue.

The issue is:

When we "close" Skype or Banshee, or Korganizer or many many others, it is common that, after we do that, **we have an icon on the panel (near the clock).

However, that has not been the case here.

Once I do that, I have no icon on the panel, near the clock, as a result, I can't easily re-display the application window as normally should happen.

How can make those icons appear on the panel ?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Do you have your "Notification Area Applet" in your panel? that's the place where all the applications goes when minimized to tray or closed while running (as in the case of banshee, rhythmbox and many more).

I would also suggest you to have the "Indicator Applet" http://launchpad.net/indicator-applet in order to have a different tray for having useful applications at the reach of a clic.

This applets can be added to your panel, by right clicking on it and choose "Add to Panel", then simply identify those applets that you need, and drag them to the panel.

Give this a chance and please let us know if this helps.

share|improve this answer
    
I've not read your answer yet. I wanted to add that, this same issue happens with Korganizer. I would like to see it on the system tray, but they don't appear. I have Skype 2.2.25 Beta I believe. But as mentioned the same happen with OTHER programs. –  MEM May 4 '11 at 21:24
    
In the System Monitor, have you tried the menu "View", option "All Processes"? see my update. This will show you all the processes, which may include those hidden. Please inform. –  Geppettvs D'Constanzo May 4 '11 at 23:11
    
Please have a look to my second update. Thanks. –  MEM May 4 '11 at 23:15
    
Now I get your point. Good luck! –  Geppettvs D'Constanzo May 5 '11 at 0:00
add comment

First install the package wmctrl

Then open a Terminal and run.

 wmctrl -a skype

That should make the window visible. If it doesn't work run

wmctrl -l 

look for a matchinhg window title and replace skype in the first command with the window title

share|improve this answer
    
Thks. Please have a look into my update. cheers. –  MEM May 4 '11 at 21:28
add comment

Run the command ps -aux in a terminal and you will see a list all the open processes your machine is running. The second column indicates the PID of each process, and you can kill any process using kill [PID]

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.