Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello I have actually successfully created a live Ubuntu USB (12.04.3 64-bit on 8GB LiveUSB) using unetbootin, however it is not persistent and will not boot on a Mac.

Or, if anyone has any suggestions on how to edit the .iso file so it boots from a Mac and is persistent, that would be great too. I am running OSX Mavericks so the application would have to run on Mavericks too.

I tried following http://ubuntuforums.org/showthread.php?t=2174630 ans, as suggested below, chose GUID partition (not MBR) and then add persistent word in grub.cfg file. and after I booted and changed a few settings, I tried to reboot using the restart option in the ubuntu menu, and it didn't work. I manually powered my computer off and on, but when I tried to boot the second time, I got past the Ubuntu logo and then my screen went black. I tried this some more times and got the same result. here is my text from the grub.cfg file:

if loadfont /boot/grub/font.pf2 ; 
then set gfxmode=auto insmod efi_gop insmod efi_uga insmod gfxterm terminal_output gfxterm 
fi 

set menu_color_normal=white/black   
set menu_color_highlight=black/light-gray 

menuentry "Try Ubuntu without installing" 
{ set gfxpayload=keep linux /casper/vmlinuz.efi persistent file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash -- 
initrd  /casper/initrd.lz } 

menuentry "Install Ubuntu" 
{ set gfxpayload=keep linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash -- 
initrd  /casper/initrd.lz }


menuentry "Check disc for defects" 
{ set gfxpayload=keep linux /casper/vmlinuz.efi boot=casper integrity-check quiet splash -- 
initrd  /casper/initrd.lz }
share|improve this question
    
Which version of Ubuntu and what kind of Mac? Are you using 32bit or 64bit image? More details please. –  Jo-Erlend Schinstad Jan 7 at 2:32
1  
It is version 12.04.3, and I am using a 64 bit image. I have an 8gb usb drive –  Jeremy Gleeson Jan 8 at 1:02
add comment

2 Answers 2

I followed following link to create live linux USB: http://ubuntuforums.org/showthread.php?t=2174630 Instead of MBR choose GUID partition and then add persistent word in grub.cfg file. It worked for me.

share|improve this answer
1  
I tried this and after I booted and changed a few settings, I tried to reboot using the restart option in the ubuntu menu, and it didn't work. I manually powered my computer off and on, but when I tried to boot the second time, I got past the Ubuntu logo and then my screen went black. I tried this some more times and got the same result. here is my text from the grub.cfg file: –  Jeremy Gleeson Jan 8 at 4:19
1  
if loadfont /boot/grub/font.pf2 ; then set gfxmode=auto insmod efi_gop insmod efi_uga insmod gfxterm terminal_output gfxterm fi set menu_color_normal=white/black set menu_color_highlight=black/light-gray menuentry "Try Ubuntu without installing" { set gfxpayload=keep linux /casper/vmlinuz.efi persistent file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash -- initrd /casper/initrd.lz } menuentry "Install Ubuntu" { set gfxpayload=keep linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash -- initrd /casper/initrd.lz } –  Jeremy Gleeson Jan 8 at 4:22
1  
menuentry "Check disc for defects" { set gfxpayload=keep linux /casper/vmlinuz.efi boot=casper integrity-check quiet splash -- initrd /casper/initrd.lz } –  Jeremy Gleeson Jan 8 at 4:22
1  
also if you know of a way to make grub so that it automatically boots to the "try ubuntu without installing", that would be appreciated also –  Jeremy Gleeson Jan 8 at 4:23
add comment

Actually, I'm using Mac Air 2013, which is 64 bit.I've installed ubuntu 13.10 64-bit version. I exactly followed same instructions, and in fact i've used it for so many times. At this point what you can try is follow what is says and this time follow as it is. I mean select MBR not GUID. If you don't have grub.cfg file in your boot folder, that's fine. But, check syslinux.cfg file for the word persistent. If it's there, that should work perfectly. I mean it did work for me, I hope that would work for you as well. Try to play with .cfg files and you'll sure can do it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.