Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to copy/paste a 4 column table from LibreOffice Calc to LibreOffice Writer but when I paste it, it makes a table extraction from Calc. I also created a table in LibreOffice Writer using the Table tool in Writer an tried to paste the data from the Calc Table into the Writer Table. It created yet the same thing, another Calc Table copy.

So how can I grab the content of a 4 column table in Calc and paste it in a 4 column table from Writer.

share|improve this question

6 Answers 6

up vote 15 down vote accepted

Can I suggest, in Writer, choose Edit - Paste Special. Then select "Formatted Text". This will paste the text in a table which you can then format/add borders etc.

share|improve this answer
    
True thank you. –  Luis Alvarado May 5 '11 at 17:59
4  
does not seem to work when pasting several columns into an existing table in writer. It will paste all columns into one single cell of the table instead several columns. –  n3rd Sep 28 '11 at 2:33
1  
Edit->"Inhalte einfügen"->HTML or "Formatted Text" work great for me. Thanks! –  alfonx Mar 14 '12 at 19:05
1  
Same problem faced by myself. Solution work only after i also did the trick suggested by @Alan –  kuldeep.kamboj Mar 22 '13 at 5:45

if you fail to update the table contents by pasting, try pasting the data to somewhere empty on the page first, and the copy it back into the table, which works for me

share|improve this answer

This can be done via Edit -> Paste Special (Ctrl + Shift + V) and then select "Formatted Text". However, you have to first select an empty space in the document, e.g. a normal paragraph not a cell in a table.

Now you will see your table from Calc pasted into Writer. In the next step you can now select this table and copy and paste it into your original table. If you try to directly paste into your original table all infos will be pasted into the first cell instead of several columns or rows, respectively.

share|improve this answer

This didn't work for me as it created dozens of tiny separate tables.

I then found a simple way around it as follows. (I was working with a large spreadsheet table about 50 rows and 10 columns.)

  1. In calc select the area reqired and copy it [ctrl - C]
  2. in writer on a plain bit of the page paste the clipboard as UNformatted text. It will paste with tabs between the cell data and carrige returns at the ends of the rows
  3. Select the whole text and use [table] [convert] [text to table] using the default settings

Works like magic

share|improve this answer
    
This answer changed my life forever. –  OregonTrail Oct 28 '13 at 7:15

I tried all the different options offered by Edit -> Paste Special (Ctrl + Shift + V) and the one that worked best for me was the option of pasting it as HTML. This way it kept all the formatting and colors. It was a complex table with 11 columns and more than 200 rows with cells of different sizes.

All formating kept.

If it makes any difference I'm using Libreoffice 4.2.6.2. It might work different on earlier versions.

Hope it helps.

share|improve this answer

My preferred way to paste (formatted) tables from calc to writer is via the html editor of libreoffice. Do this:

1) Copy the table from calc

2) Paste it in the HTML editor

3) Copy again

4) Paste it in writer

You will have your table pasted as a table (with the right number of columns and rows) and with a good part of formatting conserved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.